Manjaro 20.08 hplip rejects its own ppd files on raspberry pi 4b

Having been very impressed by Manjaro for Raspberry Pi 4 (4GB) on nearly every front, I was surprised to find this problem.

Using hplip (gui or cli) installed from the official stable repository, I can detect my HP Deskjet 2130 over USB, including serial number, but when it comes time to install the device, the provided PPD file is rejected. Note that I had no problems adding this printer in Raspberry Pi OS (even its 64bit beta) and OpenSUSE 15.2 Leap, neither of which use individual PPD files. Manjaro is much faster than these others, so I’d like to fix this and make my switch permanent. Any suggestions from forum gurus would be greatly appreciated!

Rick, new member

Is CUPS running? If not:

$ sudo systemctl enable org.cups.cupsd.service
$ sudo systemctl start org.cups.cupsd.service

That fixed it! It turns out cups was not even installed. But installing that, plus your lines did the trick. Many thanks, mparillo!

We don’t enable cups by default, since having printers attached to SBC’s is not really that common. But glad it fixed it for you. :wink:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.