Manjaro 20.0.3 installed in Virtualbox (Windows 10) Error [invalid or corrupted package]

Hope you all safe.
I installed Manjaro 20.0.3 Gnome iso and also already tried KDE in virtualbox on Windows 10 but received this error running sudo pacman -S base-devel
or updating sudo pacman -Syu. Even when packages downloaded successfully.
How do you solve this?

error: make: signature from “Evangelos Foutras evangelos@foutrelis.com” is invalid
:: File /var/cache/pacman/pkg/make-4.3-3-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

and more

EDIT:
time is synced.
Other commands tried but same error:
sudo pacman -Scc
sudo pacman-mirrors --fasttrack && sudo pacman -Syyu

Hello pagkly
please do pacman -Syu base-devel instead
best Regards, Julius

EDIT:
furthermore, check that your computers date and time is correct
EDIT on EDIT:
If you would like to use a more user-friendly package manager you should use pamac:
pamac install base-devel

Run pacman -Scc then run again

@julius-gu
Hi thanks
Clock is set correctly
It hangs when I did pamac install base-devel
If I do pacman -Syu base-devel then this error

:: File /var/cache/pacman/pkg/binutils-2.34-5-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: util-linux: signature from “Christian Hesse eworm@archlinux.org” is invalid
:: File /var/cache/pacman/pkg/util-linux-2.36-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: gcc: signature from “Evangelos Foutras evangelos@foutrelis.com” is invalid
:: File /var/cache/pacman/pkg/gcc-10.1.0-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: glib2: signature from “Jan Alexander Steffens (heftig) jan.steffens@gmail.com” is invalid
:: File /var/cache/pacman/pkg/glib2-2.64.4-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

@bhh
It would remove unused repo but still same error

hello pagkly,

  • just to make sure, check the time with timedatectl
  • the following will remove verifying the gpg keys, which is not recommended (security) but just to see whether the issue lies there, try :
    cp /etc/pacman.conf /etc/pacman.conf.backup
    sudo nano /etc/pacman.conf
    find #SigLevel = Optional TrustAll
    and change it to SigLevel = Never

you can undo this change if you decide to by
sudo mv /etc/pacman.conf.backup /etc/pacman.conf

best Regards, Julius

timedatectl
Local time: Wed 2020-08-26 06:37:31 AEST
Universal time: Tue 2020-08-25 20:37:31 UTC
RTC time: Tue 2020-08-25 20:37:26
Time zone: Australia/Melbourne (AEST, +1000)
System clock synchronized: yes
NTP service: active
RTC in local TZ: no

Already did what you suggested with the pacman but still same error as before.

Please do not disable signature validation!

Delete the pacman cache with sudo pacman -Scc as said here or press “Y” when pacman asks Do you want to delete it? [Y/n]. Pacman will then redownload the package while executing sudo pacman -S base-devel.

You can also try sudo pacman-mirrors --fasttrack && sudo pacman -Syyu and repeat the steps above, if the issue still persists. Then pacman will fetch the packages from new mirrors.

@luoe
Packages downloaded but still same error

error: python: signature from “Felix Yan felixonmars@archlinux.org” is invalid
:: File /var/cache/pacman/pkg/python-3.8.5-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: glib2: signature from “Jan Alexander Steffens (heftig) jan.steffens@gmail.com” is invalid
:: File /var/cache/pacman/pkg/glib2-2.64.4-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: librsvg: signature from “Jan Alexander Steffens (heftig) jan.steffens@gmail.com” is invalid
:: File /var/cache/pacman/pkg/librsvg-2:2.48.8-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: llvm-libs: signature from “Evangelos Foutras evangelos@foutrelis.com” is invalid
:: File /var/cache/pacman/pkg/llvm-libs-10.0.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

We also have a newer ISO with updated packages: Gnome 20.1-rc4

For the corrupted package thing. Did you update to the latest keyring? Check our Troubleshoot.

I wanted you to give a link, but it is not possible in this … forum .
Please go to archived.forum.manjaro.org

Ach has changed default compression to zstd.

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

You will find the info in the slightly older announcements.

@banjo
still same error

@philm
Same thing after reinstalling with 20.1

You probably have wsl2 activated.

I can’t post link here so search Google for:

  • “Corrupted downloads over network with hyperv backend”

and click the first link.

Regards,

Nicolas.

Need valid key…