MangoHud shows 0 CPU wattage with Nvidia GPU but shows values with integrated Radeon GPU

Hello, I want to know what settings can I do to see CPU wattage with Nvidia GPU.
I tried installing zenpower3-dkms from AUR repository after reading some threads but when I try to load zenpower3, it shows me “modprobe: FATAL: Module zenpower3 not found in directory /lib/modules/6.1.9-1-MANJARO”

These are the screenshots of MangoHud with different GPUs.


I am using optimus-manager and optimus-manager-qt to change GPUs.

Output of inxi -G:

Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nvidia
v: 525.85.05
Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
driver: amdgpu v: kernel
Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo
Display: x11 server: X.Org v: 21.1.6 driver: X: loaded: modesetting,nvidia
dri: radeonsi gpu: amdgpu resolution: 1920x1080~120Hz
API: OpenGL v: 4.6.0 NVIDIA 525.85.05 renderer: NVIDIA GeForce GTX

New to this, kindly help me. Thank you very much.

Did you install the linux-headers for kernel 6.1 ?

try to :mag: “dkms”

1 Like

Yes. It solved the issue. Thank You.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.