Mangohud not working

I’ve installed Mangohud and tried to use it with Steam Proton and Lutris but it just won’t display anything, Mangohud is enabled in Lutris, in Proton launch options i’ve set mangohud full %command% but it isn’t working.

Arch-based distributions

If you are using an Arch-based distribution, install mangohud and lib32-mangohud with your favourite AUR helper. mangohud-git and lib32-mangohud-git are also available on the AUR if you want the up-to-date version of MangoHud.

I guess you installed Mangohud properly?
//EDIT: What happens when you try the help examples?


OpenGL: mangohud glxgears
Vulkan: MANGOHUD=1 vkcube
Steam: set your launch option to mangohud %command%
Lutris: add mangohud to the Command prefix setting
OpenGL with dlsym: MANGOHUD_DLSYM=1 mangohud glxgears
Custom config options: MANGOHUD_CONFIG=“gpu_stats=0,font_size=12” mangohud glxgears

//EDIT2: Try to disable the Steam overlay for a test maybe there is a conflict.

Yes i did it works in vkcube through terminal but not in any games.

What am i supposed to do with this?

Does Mangohud actually work with Intel UHD? Specifically UHD 620.

As long the gpu support vulkan,should be fine,I have a Intel HD 630 and a 1050 Ti and both works with mangohud.

full? that doesn’t seem right,it should be only mangohud %command%

I also tried MANGOHUD=1 and mangohud but didn’t work either

What games are you trying? did you try MANGOHUD_DLSYM=1 mangohud %command%?

Also,the steam you have is steam-manjaro?

Yes i have steam-manjaro that’s the one i use, i’ve tried all of those commands but none of them worked, the only command that actually works is mangohud vkcube in the terminal.

Regarding the games i have tried Max Payne, GTA San Andreas, Sonic Mania, Torchlight 2 and Starcraft Brood War Mangohud won’t display in any of my games even in Lutris.

Thats very weird actually,did you also change the proton version? I know 5.13 has some issues with mangohud in the past but it should be fixed already,but just in case switch to proton 5.0.10 or below just to see if mangohud its working.

I’ve tried many different versions none of them worked, the only thing that works is the mangohud vkcube terminal command and nothing else.

having the same issues, it works with DXVK games and glxgears but nothing else on Steam or other OpenGL games

I have a Nvidia GTX 1060 6GB card using the latest Nvidia driver


I was able to get it working with OpenGL by doing

MANGOHUD_DLSYM=1 mangohud gamecommand

but I still can’t get it to work with any OpenGL games on Steam itself.

It doesn’t work for me regardless of Vulkan or OpenGL