Manajro Cinnamon mouse lag

Hi everyone,

I’ve been using Manjaro with Cinnamon for two years now and recently upgraded my notebook to a Dell Precision 5560. But unfortunately, the whole system feels laggy and unresponsive. CPU load is at 5% most of the time and RAM never crosses 30%. I also use proprietary drivers.

The issue is most noticable when moving around windows. It feels like the mouse is always half a second behind my actual input.

Could this be a mouse acceleration issue, or just general system lag?

xinput-props for the mouse:

Device 'Dell Computer Corp Dell Universal Receiver Mouse':
	Device Enabled (202):	1
	Coordinate Transformation Matrix (204):	2.000000, 0.000000, 0.000000, 0.000000, 2.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Natural Scrolling Enabled (332):	0
	libinput Natural Scrolling Enabled Default (333):	0
	libinput Scroll Methods Available (334):	0, 0, 1
	libinput Scroll Method Enabled (335):	0, 0, 0
	libinput Scroll Method Enabled Default (336):	0, 0, 0
	libinput Button Scrolling Button (337):	2
	libinput Button Scrolling Button Default (338):	2
	libinput Button Scrolling Button Lock Enabled (339):	0
	libinput Button Scrolling Button Lock Enabled Default (340):	0
	libinput Middle Emulation Enabled (341):	1
	libinput Middle Emulation Enabled Default (342):	0
	libinput Accel Speed (343):	-0.080645
	libinput Accel Speed Default (344):	0.000000
	libinput Accel Profiles Available (345):	1, 1
	libinput Accel Profile Enabled (346):	1, 0
	libinput Accel Profile Enabled Default (347):	1, 0
	libinput Left Handed Enabled (348):	0
	libinput Left Handed Enabled Default (349):	0
	libinput Send Events Modes Available (317):	1, 0
	libinput Send Events Mode Enabled (318):	0, 0
	libinput Send Events Mode Enabled Default (319):	0, 0
	Device Node (320):	"/dev/input/event7"
	Device Product ID (321):	16700, 9492
	libinput Drag Lock Buttons (350):	<no items>
	libinput Horizontal Scroll Enabled (351):	1
	libinput Scrolling Pixel Distance (352):	15
	libinput Scrolling Pixel Distance Default (353):	15
	libinput High Resolution Wheel Scroll Enabled (354):	1

Can you post ```inxi -Fza`` on console ?
An which mouse do you and where it is connected.

System:
  Kernel: 5.18.0-1-rt11-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/vmlinuz-5.18-rt-x86_64
    root=UUID=64790711-e1e6-4147-933c-2c561b6974b5 rw quiet
    cryptdevice=UUID=c0ca5b90-17ea-4bd2-87f3-ce3ef4918246:luks-c0ca5b90-17ea-4bd2-87f3-ce3ef4918246
    root=/dev/mapper/luks-c0ca5b90-17ea-4bd2-87f3-ce3ef4918246 apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Cinnamon v: 5.2.7 tk: GTK v: 3.24.34 vt: 7 dm: LightDM v: 1.30.0
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Precision 5560 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0NG7N9 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.6.2 date: 11/13/2021
Battery:
  ID-1: BAT0 charge: 84.3 Wh (100.0%) condition: 84.3/84.3 Wh (100.0%)
    volts: 13.0 min: 11.4 model: BYD DELL M59JH1B type: Li-poly
    serial: <filter> status: full
CPU:
  Info: model: 11th Gen Intel Core i7-11850H bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 built: 2020 process: Intel 10nm family: 6
    model-id: 0x8D (141) stepping: 1 microcode: 0x3E
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
    L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 1581 high: 2595 min/max: 800/4800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 968 2: 970 3: 801
    4: 1474 5: 2595 6: 1425 7: 1270 8: 977 9: 1522 10: 1988 11: 1178 12: 1736
    13: 2076 14: 2472 15: 2344 16: 1502 bogomips: 79872
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen12.1 process: Intel 10nm built: 2020-21 ports:
    active: DP-3,eDP-1 empty: DP-1,DP-2 bus-ID: 00:02.0 chip-ID: 8086:9a60
    class-ID: 0300
  Device-2: NVIDIA GA107GLM [RTX A2000 Mobile] vendor: Dell driver: nvidia
    v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Ampere process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:25b8
    class-ID: 0302
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-11:5 chip-ID: 0c45:672e class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 9504x2880 s-dpi: 70
    s-size: 3460x1048mm (136.22x41.26") s-diag: 3615mm (142.33")
  Monitor-1: DP-3 pos: top-right model: Dell C2722DE serial: <filter>
    built: 2021 res: 5120x2880 hz: 60 dpi: 218 gamma: 1.2
    size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  Monitor-2: eDP-1 pos: primary,bottom-l model: Sharp 0x1516 built: 2021
    res: 4384x2740 hz: 60 dpi: 331 gamma: 1.2 size: 336x210mm (13.23x8.27")
    diag: 396mm (15.6") ratio: 16:10 modes: 3840x2400
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Tiger Lake-H HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 3-4.3:6 chip-ID: 413c:c00d
    alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 class-ID: 0300
    chip-ID: 8086:43c8 class-ID: 0403
  Device-2: Dell C2722DE type: USB driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.18.0-1-rt11-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.0 running: yes
  Sound Server-4: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
    driver: r8152 bus-ID: 2-4.2:4 chip-ID: 0bda:8153 class-ID: 0000
    serial: <filter>
  IF: enp0s13f0u4u2 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: br-a51ab652e1d6 state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  IF-ID-3: veth3b36a8f state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-4: vethcfd2a3e state: up speed: 10000 Mbps duplex: full
    mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-14:8 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Drives:
  Local Storage: total: 953.87 GiB used: 105.54 GiB (11.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC711 NVMe 1TB
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 41001131
    temp: 49.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 950.91 GiB size: 934.91 GiB (98.32%)
    used: 105.41 GiB (11.3%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-c0ca5b90-17ea-4bd2-87f3-ce3ef4918246
  ID-2: /boot raw-size: 1.95 GiB size: 1.89 GiB (96.54%)
    used: 138.5 MiB (7.2%) fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-3: /boot/efi raw-size: 400 MiB size: 399.2 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 55.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 613 Uptime: 3h 6m wakeups: 88 Memory: 31.09 GiB
  used: 20.72 GiB (66.6%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: 2316
  apt: 1158 lib: 290 pacman: 1158 lib: 290 flatpak: 0 Shell: Zsh v: 5.9
  running-in: guake inxi: 3.3.19

The mouse is a wireless dell mouse connected via USB-C hub.

Can you try another kernel. E.g.: kernel 5.15.
You are using a realtime kernel, is this nessecary ?

I’m just using thee newest stable Kernel. Real time is not really a requirement. Will let you know as soon as I can test another kernel.

Switching Kernels caused no noticeable improvement. It still feels like all of cinnamon (most noticably the mouse pointer) gets slower the moment I open any window.

Not sure if it helps with any system lag but you can alter mouse sensivity and speed in system settings on cinnamon

I think, I kind of solved it.

I basically did two things:

  • First, I changed the mouse acceleration profile to “flat” using this post in the Mint forums. This helped a lot with the mouse pointer not moving in sync with my physical mouse
  • Second, I gave the Cinnamon process the priority “very high” in the system monitor. This probably helped the most.

I still get the lags when I do extremely demanding tasks like rendering stuff on the CPU or during benchmarks, but other than that it works fine. I have no idea, why the cinnamon process got started with “normal” scheduling priority, but now it all works as intended.