Making the Nvidia card downclock itself


I am using a desktop PC with an Nvidia 1080Ti. Since I switched to Manjaro from Windows… I noticed that the GPU fan is slightly louder than what it should be normally. After some investigation and checking the arch wiki, I found this in the nvidia settings.

It seems that the nvidia clock is stuck at the highest setting, if I understand correctly… since level 3 is highlighted. However I’m not sure how to get it to change its level based on the amount of load. Is this possible?

I have an option for mine under preferred mode to change from auto to adaptive to prefer maximum performance.I have mine set to auto.

Hello @9a3eedi :wink:

Take also look at the official README of the NVIDIA driver: Index of /XFree86/Linux-x86_64

There is a slight new service: nvidia-powerd.service

systemctl enable --now nvidia-powerd.service
systemctl status nvidia-powerd.service

Seems promising when I read this: Chapter 23. Dynamic Boost on Linux

Or you can unlock cool bits by Appendix B. X Config Options
and use for example: Roberto Leinardi / GreenWithEnvy · GitLab to control the fans.

I tried the preferred mode to auto from adaptive. However, it doesn’t seem to be getting set, even after restarting the computer. I feel like there might be something else I need to do? As you can see in the screenshot, the current mode is still adaptive.

The nvidia power service seems like what I might be looking for. I tried the nvidia-powerd.service, but it didn’t work. Main error in journalctl is that there’s “No matching GPU found”. After checking the README, it seems that this service mainly applies to laptops. However, I am on a desktop.

Don’t compare Windows to Linux behavior, it is not the same.

If you wait doing nothing it will step down to other lower power states. It takes longer on Linux, and will ramp up as soon as you do something.

//EDIT: see also this old and useless thread If you have GPU clock boost problems, please try __GL_ExperimentalPerfStrategy=1 - Linux - NVIDIA Developer Forums

1 Like

Is this because I have compositing enabled on Plasma?

How do you know that what you’ve stated is true, if it will always go back to the higher power states as soon as you do something? Are there any tools I can use to monitor the power state apart from the GUI?

No, it is because Nvidia drivers on Linux are dog :poop:

Sounds like an issue that can’t be solved. Oh well, I guess I’ll just tolerate it. I’m glad this is a desktop at least, and not a laptop where I might get battery life issues

You have tools then if you want to customize things, but yeah by default this is how it works. I’m surprised you have noticeable fan noise but I don’t own your hardware. On my side I can see it doesn’t go down quick when I stop doing intensive graphical things, but my fans on my GPU don’t ramp up unless I do some serious work.

GreenWithEnvy is one of the tools you could use to manage the fan curve (and many other things too ;)). I was doing that too at some point with a text config and a terminal tool I can’t recall, but there are plenty of tools to mitigate the fan noise issue.

The fan noise is very slightly higher compared to when I was using Windows. Worth noting that my GPU is a blower-type, and there’s a rattling problem at a certain range of RPMs, so it’s more obvious than most GPUs. This is what prompt me to investigate the power modes in the nvidia tool.

I’ve recently started using GreenWithEnvy to solve another issue I had related to gaming (turns out what I needed was gamemode though). It’s a good tool, and gives a better idea of what’s happening with the GPU.

Thank you for the help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.