Makepkg can't detect already installed jre

I’m using GraalVM instead of ordinary JVM.
When I’m going for makepkg, I’m getting an error of missing dependency.

==> Missing dependencies:
  -> java-runtime>=17.0
echo $PATH

so, I edited depends in PKGBUILD to ‘graalvm-jdk>=17.0.7’ , also tried ‘graalvm-jdk>=17.0.7+8.1’ and few other similar things but makepkg still isn’t able to detect jdk.
Even tried including export JAVA_HOME path in PKGBUILD but it is still giving me missing dependency error.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Which package do you want to install?

You have two options:

  1. Modify the PKGBUILD of you package and remove the java-runtime entry from the requires field.
  2. Modify the PKGBUILD of GraalVM that it provides java-runtime.

Thanks! 1st option worked! btw I’m installing cisco packet tracer.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.