MakeMKV not detecting external drive, encountering issues with downgrading

Hi everyone,

This is my first post here, so apologies if it seems like I’m still getting into the proverbial swing of things. In any event, I’ll get straight to the point.

I was looking into Blu-Ray support for Linux, and tried various options (running a Windows-compatible player through Wine, trying workarounds with VLC, etc.), before attempting to use MakeMKV from the AUR. It runs well enough, with one major exception… it doesn’t detect my Blu-Ray drive!

I looked around on the MakeMKV forums, and found exactly one poster who was similarly using Manjaro and encountering the issue. He suggested that people downgrade MakeMKV (though I can no longer find the version he recommends, but whatever), then reboot.

To this end, I tried the following from the terminal, after installing Downgrade via the instructions on the Manjaro Wiki:

$ downgrade makemkv

I was met with:

Downgrading from A.L.A. is disabled on the stable branch. To override this behavior, set DOWNGRADE_FROM_ALA to 1 .
See Downgrading packages - Manjaro Linux for more details.

Unable to downgrade makemkv

After some more digging, I tried to do the following:


However, this does not appear to have worked. Any suggestions as to how to get the program to detect my drive, or even an entirely different method for Blu-Ray support, would be appreciated.

What version? All you have to do is edit the pkgver in the PKGBUILD and update the checksums.

downgrade only works with the repo package database, not foreign packages.

There is normally a message during the installation of makemkv, did you consider it?
Something like this:

That only fixes it once, after reboot the kernel module is not automatically loaded. Did you read the message after installation?

"Starting from 1.10.8 the /dev/sgX device that corresponds to the drive is required. You may have to load the sg kernel module in order to create the device. To enable module autoloading run the following command as root and reboot:

echo sg > /etc/modules-load.d/sg.conf"

source: AUR (en) - makemkv

Unfortunately, I checked the post again, and it seems I remembered it wrong. He doesn’t recommend any version in particular, so it’s possible I conflated his post with another, less-relevant one. Thanks for the info, though.

This worked! Thank you so much!!! I was going to post this as an edit, but I ran into issues, so I figured I’d just re-post, instead lol. (Hence the deleted post just above this.)

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.