Makemkv don't see /dev/sr0

Hi all,
I’m trying to rip a Cd with Makemkv. Th CD is in the device “/dev/sr0”

Listing the device I see

    ~  sudo ls -lh /dev/sr*                                                                                                                              ✔ 
brw-rw----+ 1 root optical 11, 0 11 giu 19.32 /dev/sr0
    ~  sudo ls -lh /dev/sg*                                                                                                                              ✔ 
zsh: no matches found: /dev/sg*
    ~      

But makemkv says

MakeMKV v1.17.7 linux(x64-release) started
The program can't find any usable optical drives.

What I’m missing?

Is your user in the optical group? If not, it won’t have access.

1 Like

Tryed without success

Added the user to optical group

    ~  groups $USER                                                                                                                                    1 ✘ 
wheel lp sys network power mirto
    ~  sudo usermod -aG optical $USER                                                                                                                    ✔ 
    ~  groups $USER                                                                                                                                      ✔ 
wheel lp optical sys network power mirto
    ~  ls -lh /dev/sr0                                                                                                                                   ✔ 
brw-rw----+ 1 root optical 11, 0 11 giu 21.13 /dev/sr0
    ~  

Makemkv still says

MakeMKV v1.17.7 linux(x64-release) started
The program can't find any usable optical drives.

BTW vlc opens correctly a DVD in /dev/sr0

Reading the install message at install time which says

"To enable module autoloading run the following command as root and reboot:"
"  echo sg > /etc/modules-load.d/sg.conf"

also sudo modprobe sg have been reported to work

1 Like

@Lolix is correct, according to this: MakeMKV forum post

I’ll add that I did as they instructed when I installed it, and I’ve never had a problem with it detecting my optical drive.

@Lolix @ydar
You are right: adding the module solves the problem.

Thanks

1. Ensure your user is in the optical group:

sudo usermod -a -G optical <user name>

2. Add the SCSI Generic module (sg) to:
/etc/modules-load.d/modules.conf:

sudo nano /etc/etc/modules-load.d/modules.conf
  • Enter sg after any existing modules listed.

3. sudo modprobe sg - and/or - reboot, as needed.


Notes:

The modules.conf file exists to contain any additional kernel modules desired to be loaded at boot; usually entered with one module listed per line.

Any file name (for example the sg.conf mentioned) can be used in this directory, however, modules.conf is the default file already in place.

Not all distributions seem to need the sg module loaded in this fashion. In Manjaro KDE, for example, modules.conf is not populated at all (and no other file contains this module), yet MakeMkv detects a (BD) drive without issue.

I’m guessing that the sg module might only be needed with a certain range of (perhaps older) optical devices.

Thanks
Very useful informations