Make DVD player visible in Dolphin


How can I please make my physical internal DVD drive visible, in "Dolphin location. It works fine, but whether it reads a disc or not, it does not appear.

Check /proc/sys/dev/ for drives.

can’t see a thing - much to blurry

easier and copy/paste friendly and, unlike pictures, can be parsed:
ls -l /proc/sys/dev

is there an entry named cdrom in the output?

ls -l /proc/sys/dev                                                                            ✔ 
total 0
dr-xr-xr-x 1 root root 0 12 janv. 11:50 cdrom
dr-xr-xr-x 1 root root 0 12 janv. 11:50 hpet
dr-xr-xr-x 1 root root 0 12 janv. 08:54 i915
dr-xr-xr-x 1 root root 0 12 janv. 11:50 mac_hid
dr-xr-xr-x 1 root root 0 12 janv. 11:50 scsi
dr-xr-xr-x 1 root root 0 12 janv. 11:50 tty
    ~                   

A simple yes or no would have sufficed. :sunglasses:

I don’t exactly know where @Keruskerfuerst was going with this.

I don’t have any advice at the moment.

Then the entry cdrom, there should be some device nodes.
If yes, then the DVD drive does exist.

Is the DVD drive a SATA device or something else ?

Actually, /proc/sys/dev/cdrom wouldn’t exist if the device didn’t exist.
And the device node for it would be under /dev
as: /dev/cdrom - which is a symlink to the actual device (sr0 in my case)

Manjaro’s information center shows me the presence of my drive, connected in Sata.

When the vice is shown in the System settings, then the device is detected by the system.
Here is the part of dmesg related to by LG Bluy Ray burner:

[    0.975116] ata6.00: ATAPI: HL-DT-ST BD-RE  BH16NS55, 1.02, max UDMA/133
[    0.976397] ata5.00: Features: Trust Dev-Sleep NCQ-sndrcv
[    0.977085] ata5.00: ACPI cmd ef/10:06:00:00:00:00 (SET FEATURES) succeeded
[    0.977093] ata5.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
[    0.977098] ata5.00: ACPI cmd b1/c1:00:00:00:00:00 (DEVICE CONFIGURATION OVERLAY) filtered out
[    0.977320] ata5.00: supports DRM functions and may not be fully accessible

Can you also search in dmesg for that ?

My little anecdote:
I use Xfce (Thunar as file manager),
but installed Dolphin, just to test and see for myself.

Because I thought your problem could be that you simply hid the entry and could easily get it back.

I could hide the entry for the cdrom drive - and bring it back.
A few times.
But then I suddenly could not bring it back anymore - I think mounted it and then hid it.
I tried “everything” - I could not get it back.

It should have worked like this:

How to get hidden entries back to the devices list ? • KDE Community Forums

It did, a few times - but then it didn’t anymore.

I hope that this is your problem and you can solve it that way.

I couldn’t.
In the end I just deleted,
from the root account,
from a TTY (logged in as root on TTY)
every hidden file and directory in /home/user and restored from /etc/skel
(run chown -R user:user /home/user afterwards)

Perhaps a less invasive method works as well,
because this method will leave you with the default settings as they where when you first installed.
But I was just done trying.


Thank you for your feedback.
Could you tell me how to do it?

as root or sudo
dmesg | grep "SATA"

this will catch more possibilities in one go:
sudo dmesg | grep -E 'SATA|scsi|CD|cdrom|DVD'

@Ericks did you have a look at that link - to possibly just unhide the menu entry?

This is indeed one of the following possibilities of the hidden menu entry.

I have no feedback from this order

sudo dmesg | grep -E 'SATA|scsi|CD|cdrom|DVD  0|1 ✘  6s 
pipe quote>

try again - you did not include the last character
this: → ’

What about the question?

1 Like

Yes, but after checking show all items, I still don’t see my DVD player. But when I put a disc inside, it appeared, which it didn’t do before!

THANK YOU ! :smiley:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.