Majaro KDE doesn't open after install Cuda

Dear Manjaro users,
I have a problem and I want to know if anyone can help me.
I use Majaro KDE and the PC has a Nvidia graphic card. Yesterday, I installed software that needs the cuda-toolkit. I installed everything, and that worked fine. After restarting the computer, it stoped in a screen showing the message “disk clean, x/x files, x/x blocks”

Using the CTRL + ALT + F2, I could enter the system and delete the software, cuda-toolkit cuda. Restarted the computer and everything worked fine. However, I’ll need the software a lot and I have no option to install/uninstall the cuda everytime.

How can I fix this problem?

Thanks for your help


What and how?
What packages and/or steps exactly?


Oh! Thank you for your answer @cscs.

It’s the CrystalExplorer (CE). I used the debtap to create a file and the pacman -U to install it. One of the packages installed was the Cuda/toolkit.

On my personal laptop (Majaro XFCE) it worked fine. But on the Desktop I use to work (Manjaro KDE with Nvidia card) it showed the problem. The softwares (CE, cuda*) were (un)installed with pacman. After uninstalling, the system worked fine, and I tried to install the softwares again, manually using pacman… one by one. They worked fine. I restarted the computer and the message returned.