Mailspring flatpak does not let me make accounts because of missing libsecret and keyring

I installed Mailspring flatpak from Pamac. When I attempt to continue without making a Mailspring account, I get this message: “Mailspring could not store your password securely. Make sure you have ‘libsecret’ installed and a keyring is present”

However, when I check, I can find libsecret installed in pamac. Is there anything else I’m missing?

I am using Manjaro KDE on x86_64.

Check their troubleshooting?

I did, but it just tells me to install libsecret. But it’s already installed.

I was thinking since it’s a flatpak, maybe there’s a sandbox issue? But I don’t have a lot of experience with flatpak.

No it doesn’t.

Why am I getting a Password Management Error?

If you are getting a Password Management Error, it’s because something went wrong when we tried to access your computer’s keyring. This could mean that you don’t have a keyring installed on your computer, or you are using Mailspring from a user account that doesn’t have permission to access the keyring. Make sure that you aren’t on a “guest” user account or any user account without a password.

I’m on Linux (and NOT a Guest Account)

If you are getting this error on Linux, and aren’t on a guest account, it’s likely that you don’t have the proper keyring installed. Install gnome-keyring and/or libsecret from your package manager and try running Mailspring again.

" Install gnome-keyring and/or libsecret from your package manager and try running Mailspring again."

My account is not a guest user and does have a password. I figured that gnome-keyring is not applicable here since I’m using KDE, so that leaves libsecret as the only option left.

No. Do as they say:

  • no guest account
  • user with password
  • gnome-keyring
  • libsecret

Reboot. Try.

I just installed gnome-keyring (official repositories) and libsecrets is also still installed. I then rebooted my computer and tried mailspring again, but I still get the same error.

One more thing I noticed… the wizard seems like it’s struggling to work, like it’s having a hard time retrieving the “pages”, which seem to render like webpages. My internet is rock solid though, so it’s a little surprising. I’m not sure what’s causing it, but I am able to work around it by going back and forth in the initial wizard.

Is the gnome-keyring working?

//EDIT: officially they distribute a SNAP and also DEB/RPM packages (I guess the Flatpak is from community), which is what is used for the AUR package (the DEB), which I would use over a SNAP or FLATPAK.

//EDIT2: seems like I have no issue with the AUR version. As I don’t open the keyring when opening my desktop session, it asks for the keyring password when Mailspring starts and everything works. I guess it could be possible to unlock the keyring automatically when the desktop loads (see WIKI), but I’m not gonna test further for me it works with the AUR version.

//EDIT3: seems like I don’t have issue with the Flatpak version either (it asked for my keyring password, I could add a mail account), I will not try but pretty confident the SNAP version would also work properly.

Make sure you have properly installed gnome-keyring, I guess this is your issue. I would still try to remove the Flatpak, and install the AUR version for a more ‘native’ solution instead of using Flatpak.

1 Like

aur/mailspring 1.10.3-1 [+197 ~2.04] [Installed]
A beautiful, fast and maintained fork of Nylas Mail by one of the
original authors.

Works perfect…


Same here, the AUR package works perfectly fine

1 Like

2 days ago, I followed the steps in the arch link to set up gnome-keyring. Specifically, I opted to make an .xinitrc file as in the wiki page, then I restarted my computer. Mailspring still didn’t detect my gnome-keyring.

Today (without restarting since last time) I decided to uninstall the flatpak and install the native version in the AUR. It works! It asked me to set a password for my keyring and now I got my email account set up.

I generally prefer native versions, but I was recommended to use the flatpak version from somewhere. I guess I’ll stick to native then.

Thank you very much @omano for your prompt replies and your patience, as well as the rest

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.