Magic trackpad 2 paired but not working

I am brand new to Linux. I installed Ubuntu 20.04 and was able to pair and use an Apple Magic Trackpad 2. I then installed Manjaro 20.1 and set it up for dual boot. I was able to pair the trackpad but it doesn’t connect. I tried another old Apple trackpad and had the same experience, it pairs but does not connect after. The only way I can use the Magic Trackpad 2 is using the USB cable. My motherboard has the Intel AX201 chipset.

I booted back to Ubuntu and unpaired the Trackpad 2 and tried Manjaro again with no change.

I was able to pair and use AirPods Gen 1 and Cowin Noise Cancelling Headphones without any problem.

Not sure what else to try as I haven’t found this exact problem in the forum.

Kernel 5.8.18-1
XFCE desktop

I finally got it working! I unpaired the trackpad. Started Bluetooth Manager and hit on the search button. After it listed the Magic Trackpad I selected it and clicked connect from the Device menu. After it connected the mouse functionality worked.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.