Magic the Gathering Online installation crashes with Lutris

Hi All,

I recently installed the KDE version of Manjaro 20.2. I wanted to play some magic the gathering online as I have a subscription for it, I did a bit of research about gaming on linux and found out about lutris. I tried to install the game however when it starts setting it up it returns the following error:

An error occurred downloading the following resource:

Date: 12/25/2020 1:15:29 AM

See the setup log file located at 'C:\users\spas\Temp\VSDfe44.tmp\install.log' for more information.

Does anyone played this game on Manjaro?
I am not sure how to proceed with this I have never really played games on linux before and I am not familiar with the inner workings of linux so help will be appreciated :slightly_smiling_face:
I am running this on a Yoga slim 7 with Ryzen 4800u.

Below is the inxi -Fazy output. Please let me know what otherr info I can provide.

  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=b00fcc9c-dd35-4bf5-8c8b-ad95ad782688 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 mem_sleep_default=deep 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 82A2 v: Yoga Slim 7 14ARE05 
  serial: <filter> Chassis: type: 10 v: Yoga Slim 7 14ARE05 serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 
  v: SDK0J40709 WIN �������������������������������� serial: <filter> 
  UEFI: LENOVO v: DMCN34WW date: 08/17/2020 
  ID-1: BAT1 charge: 22.6 Wh condition: 58.1/60.7 Wh (96%) volts: 15.1/15.4 
  model: Celxpert L19C4PF4 type: Li-poly serial: <filter> status: Discharging 
  cycles: 31 
  Info: 8-Core model: AMD Ryzen 7 4800U with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600106 L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 57517 
  Speed: 2039 MHz min/max: 1400/1800 MHz boost: enabled Core speeds (MHz): 
  1: 1789 2: 1981 3: 1397 4: 1396 5: 1397 6: 1397 7: 1397 8: 1397 9: 1330 
  10: 1370 11: 1275 12: 1353 13: 1358 14: 1315 15: 1397 16: 1396 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus ID: 03:00.0 
  chip ID: 1002:1636 
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus ID: 1-4:3 
  chip ID: 04f2:b6cb serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: amdgpu,ati 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x174mm (12.2x6.9") 
  diag: 355mm (14") 
  OpenGL: renderer: AMD RENOIR (DRM 3.39.0 5.9.11-3-MANJARO LLVM 11.0.0) 
  v: 4.6 Mesa 20.2.3 direct render: Yes 
  Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 03:00.1 
  chip ID: 1002:1637 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
  driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x bus ID: 03:00.5 
  chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 03:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus ID: 01:00.0 
  chip ID: 8086:2723 
  IF: wlp1s0 state: up mac: <filter> 
  Local Storage: total: 953.87 GiB used: 178.38 GiB (18.7%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFS001TD9TNG-L3A0B 
  size: 953.87 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: 80050C10 scheme: GPT 
  ID-1: / raw size: 476.31 GiB size: 467.83 GiB (98.22%) 
  used: 178.36 GiB (38.1%) fs: ext4 dev: /dev/nvme0n1p5 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 39.1 C mobo: N/A gpu: amdgpu temp: 38.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 367 Uptime: 10h 57m Memory: 15.08 GiB used: 4.67 GiB (31.0%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1330 lib: 356 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.08

So I’m gonna shoot off the basics here…

First is the generic wine… this is probably the hardest to use one its own… but also a good place to look for how supported something might be:

WineHQ - Magic: The Gathering Online 4.x

Then we can look at lutris itself - which makes use of custom bundles/scripts that work for different games:

Magic The Gathering Online - Lutris

Go with that probably :wink:

(note for DDG users … of course there are bangs for these, ex: !lutris magic the gathering)

This is DotNet Framework 4.5.2, If it fails to download the pre-requisites from Lutris, you can manually download them from your browser, and place them in Lutris cache folder ~/.cache/lutris/ (not sure the exact sub folder yet) [///EDIT: it is actually downloaded from the Magic installer, and it works on my side so I suggest to restart the installation from Lutris as it seems to work for me ///] so it can execute them inside your game prefix to proceed to installation.

Hi cscs and omano,

Thank you for the quick replies.
I tried to re-running the installation. In lutris when I click on the game it says Play. But clicking it causes the same error. I tried re-installing the game but I get the same error it comes right after accepting the license agreement for .NET Framework.
Perhaps I haven’t set up lutris correctly? I just downloaded whatever was in the download manager.

There might be an issue with the installation of DotNet, I’ll try to have a look later, didn’t really have time when I replied the other day.

I have moved to Gnome, for some reason the game installed and works flawlessly under it. I am not sure what caused this issue on my KDE… I guess it remains unknown.