MacBookPro 2012 Boot issue

Recently I want to install manjaro on my MacBookPro (2012 Mid), it does not support UEFI. I tried to make a live USB and use VENTOY to bootup directly from the iso file, but I fail every time.

Can someone tell me what should I do? I do not like use the VM. Thank you anyway 4 reading this through patiently.

by the way I am using the old version which O downloaded in August 3rd.

It is generally suggested to use the current install media.

What do you mean by fail?

The install media is not recognized? Or you can select it to boot from, but you receive an error?

Err, actually the USB is recognized, but I always receive an error when I tried to boot from it and I am sure the media worked because I used it to install manjaro on a VM via VMWare.

What is the error ?

Sorry for making you waiting too long. During this period I make two brand new installation media to test again.
I use a new USB drive and the iso file I used to set up my VM, so I guess the media itself is not a problem.When I tried to boot-up ,it said:

No ER State object for volume OSX rolloing is not happening.Nothing to recover.

Traditional USB media
I use another working USB drive. I formatted it, then I made a installation media using the same iso.
when I tried to boot it up, it said:


This seems like a problem.

Either ventoy does not have grub, cannot initialize it, or expects grub to already be on the system.
(or refit or refind or whatever)

Please review your method there.

If in doubt … a more ‘classic’ method using dd or etcher or something might work.

But I might also worry on your mbp hardware … is this one of those weird ones with a 32-bit UEFI, but a 64-bit system ?

The Laptop I have is A1278, an 13-inch one which produced in mid 2012.
By the way, the USB tag is strange:


I am now trying a more extreme method

That is to boot up normally using Windows To Go and mount my hard disk to a VM, then install the system using the iso.

Thank you anyway to helping me.