MacbookPro (2011) touchpad ... Problem solved (hopefully)

I’m sharing my laptop touchpad PROBLEM+SOLUTION in case it’s of help to anyone else using an old MacBookPro laptop for Manjaro/Arch experiencing similar problems…

SYMPTOM: Screen cursor bouncing all over the place, selecting, clicking, editing my desktop (!) and generally behaving like a rabid input device running amuck. It would begin after the laptop had been on for a while and nothing I could do would stop it … except poweroff via a hard power button crash.

I shut down and rebooted repeatedly - detaching various USB connections - trying to figure it out. Finally, reading about how old MBP laptop owners were experiencing this within OSX, I concluded that it was the flailing gasps of my laptop’s aging touchpad.

It’s hard to prove a negative, but that crazy manic cursor behavior has not occurred again (since).

ENDNOTE: If it turns out the problem reoccurs - even with the touchpad kept disabled - then it will show that my diagnosis is incorrect and I’ll share an update accordingly.

Good luck.


1 Like

Please add a reply and move your solution bit to it and mark it solved. That way the post doesn’t show up under posts that have no solution and it’s easier to see it.

1 Like

SOLUTION: In System Settings > Input Devices > Touchpad simply turn the darn thing off under General _ Device enabled (uncheck the box).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.