Macbook Wifi not working

ls /etc/modprobe.d                                                                                                          1 ✘ 

Hmm, no blacklist.conf and no broadcom-wl.conf that may have it blacklisted it, I’m afraid that’s as far as I can help here. I’m on a 2009 mbp with the same settings working fine but on 5.10LTS kernel.

Maybe try the 5.15LTS kernel, the 6.1LTS is quite new. Install via Control Centre >> Manjaro Settings Manager.

Okayy I see. Thank you sooo much for everything anyways!

I’ll try the older kernel and update how it goes!


Ok, I think I have an idea… Your inxi after boot shows:

  Device-2: Broadcom BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme
    driver: N/A modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1

Can you create a blacklist.conf:
sudo touch /etc/modprobe.d/blacklist.conf
and add ‘blacklist bcma’ and ‘blacklist b43legacy’ (maybe try one first, then add the other, then both)
Then reboot. If it works, great, if it doesn’t delete blacklist.conf again:
sudo rm /etc/modprobe.d/blacklist.conf

Tried all the combinations still doesn’t seem to work :pp

Just deleted the file. XD

I’ll try to switch to the older kernel and see what happens!

Ok. If that doesn’t work you could try the broadcom-wl-dkms driver, this guy explains the process from giving up on b43 and installing broadcom-wl-dkms at the last post.

It’s a mbp 10,1 but it’s your exact broadcom chip bcm4331 (I’m on a bcm4322). [SOLVED] BCM4331 driver on MacBook Pro 10,1 / Laptop Issues / Arch Linux Forums .

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.