MacBook (Retina, 12-inch, Early 2015) keyboard and touchpad not working

With Debian, Ubuntu distros, Keyboard and Touchpad are operating, but not in Manjaro or other Arch family distros. Problem is I prefer Arch family distros. Please don’t close this topic prematurely. Does anyone have a solution for this. Is it a kernel module or argument I can pass to grub? The Manjaro live cd looks beautiful on Retina btw, really would love to get back to work. Thanks.

1 Like

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Have you already searched for “macbook” ?

Here is the relevant results from`inxi…" from an Ubuntu install:

Type: Laptop System: Apple product: MacBook8,1 v: 1.0 serial:
Chassis: type: 9 v: Mac-BE0E8AC46FE800CC serial:
Mobo: Apple model: Mac-BE0E8AC46FE800CC v: MacBook8,1 serial:
UEFI: Apple v: 428. date: 10/27/2021

Info: Dual Core model: Intel Core M-5Y31 bits: 64 type: MT MCP
arch: Broadwell family: 6 model-id: 3D (61) stepping: 4 microcode: 2F cache:
L2: 4 MiB bogomips: 8800
Speed: 800 MHz min/max: 500/2400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800
4: 800
Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon avx
avx2 bmi1 bmi2 bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de
ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d
fma fpu fsgsbase fxsr ht ibpb ibrs ida intel_pt invpcid invpcid_single
lahf_lm lm mca mce md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx
pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36
pti pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2
sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr

Hi There !!

The MacbookPro early2015 model has a new touchpad device. The device (05ac:0273) is not supported by current bcm5974 multitouch driver.

By default, the device is associated with the generic ‘usbhid’ driver which drives the touchpad as a single-button mouse in functionality.

I would suggest you to take a look into this Thread :

If you didn’t understand you can ask here
In the thread a guy in #10 has said that his issue was solved
You can at least try some methods available on the Internet

There was also a huge discussion in Bugzilla about this :
You can pull up a help ticket here if you didn’t receive your solution else where

Have a great day :slight_smile:

Thanks for that information, some of which I have come across before. Many of the solutions appear to have been incorporated into contemporary kernels, post 4.1. On my Kubuntu install trackpad and toucpad work, but not after sleep, which is a different problem. I just want to figure out what is activated in Ubuntu that is not in Arch, I think it may be the xf86-input-synapics or multitouch package. Kubuntu seems to rely on libinput. The xf86-input is required by Plasma which is what I tried on the Manjaro Live CD.

Other references and bread crumbs:,1/8,2/8,3_(2011)

Sorry for resurfacing this old thread, but has any new development come around? I can’t seem to find anything new on the Internet