Macbook Pro 5,4 (2009) Cannot change brightness

I recently got my hands on an old laptop my uncle would use. I originally tried ubuntu and it completely failed because I couldn’t get any internet connection (wired and wireless) and I wasn’t about to go back and forth downloading packages offline.
I’ve been meaning to try manjaro for a while and it’s a very pleasant experience so far, however, I can’t change the brightness of the backlight at all.

[spcman-puter ****]# xbacklight -dec 10
No outputs have backlight property

I eventually want to be able to control the brightness with the brightness keys (the sound and keyboard brightness keys work already). But I guess that having the backlight work is the first priority lol.

I’ve tried many things on the internet I’ve found but to no avail and would appreciate any assistance as I am very much a beginner in all things linux.

[spcman-puter ****]# inxi -Fxxz
  Kernel: 5.10.32-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 wm: xfwm4 dm: LightDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Apple product: MacBookPro5,4 v: 1.0 serial: <filter> 
  Chassis: type: 10 v: Mac-F22587A1 serial: <filter> 
  Mobo: Apple model: Mac-F22587A1 v: MacBookPro5,4 serial: N/A UEFI: Apple 
  v: MBP53.88Z.00AC.B03.0906151647 date: 06/15/09 
  ID-1: BAT0 charge: 68.0 Wh (91.3%) condition: 74.5/75.2 Wh (99.1%) 
  volts: 11.9 min: 10.9 model: SMP bq20z451 serial: N/A status: Discharging 
  Info: Dual Core model: Intel Core2 Duo P8700 bits: 64 type: MCP 
  arch: Penryn rev: A cache: L1: 128 KiB L2: 3 MiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 10083 
  Speed: 796 MHz min/max: 798/2527 MHz Core speeds (MHz): 1: 796 2: 796 
  Device-1: NVIDIA C79 [GeForce 9400M] vendor: Apple driver: nouveau 
  v: kernel bus-ID: 03:00.0 chip-ID: 10de:0863 
  Device-2: Apple Built-in iSight type: USB driver: uvcvideo bus-ID: 1-4:2 
  chip-ID: 05ac:8507 
  Display: server: X.Org 1.20.11 driver: loaded: nouveau 
  unloaded: modesetting alternate: fbdev,nv,vesa resolution: 1440x900~60Hz 
  s-dpi: 96 
  OpenGL: renderer: NVAC v: 3.3 Mesa 21.0.3 direct render: Yes 
  Device-1: NVIDIA MCP79 High Definition Audio driver: snd_hda_intel 
  v: kernel bus-ID: 00:08.0 chip-ID: 10de:0ac0 
  Sound Server-1: ALSA v: k5.10.32-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: no 
  Device-1: NVIDIA MCP79 Ethernet driver: forcedeth v: kernel port: 21e0 
  bus-ID: 00:0a.0 chip-ID: 10de:0ab0 
  IF: enp0s10 state: down mac: <filter> 
  Device-2: Broadcom BCM4322 802.11a/b/g/n Wireless LAN 
  vendor: Apple AirPort Extreme driver: wl v: kernel port: 1000 
  bus-ID: 04:00.0 chip-ID: 14e4:432b 
  IF: wlp4s0 state: up mac: <filter> 
  Device-1: Apple Bluetooth Host Controller type: USB driver: btusb v: 0.8 
  bus-ID: 4-1.1:3 chip-ID: 05ac:8213 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Local Storage: total: 465.76 GiB used: 8.43 GiB (1.8%) 
  ID-1: /dev/sda vendor: Apple model: HDD HTS727550A9E362 size: 465.76 GiB 
  speed: 3.0 Gb/s serial: <filter> 
  ID-1: / size: 449.31 GiB used: 8.43 GiB (1.9%) fs: ext4 dev: /dev/sda2 
  ID-2: /boot/efi size: 299.4 MiB used: 296 KiB (0.1%) fs: vfat 
  dev: /dev/sda1 
  ID-1: swap-1 type: partition size: 7.9 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 
  System Temperatures: cpu: 62.0 C mobo: N/A gpu: nouveau temp: 64.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 175 Uptime: 10m Memory: 3.59 GiB used: 1.54 GiB (42.8%) 
  Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1114 
  Shell: Bash v: 5.1.0 running-in: xfce4-terminal inxi: 3.3.04