Macbook Pro 2015 - Not booting up on kernel 5.7 or higher

I can’t seem to get any kernel of 5.7 (5.6 or lower is fine) or higher to boot on my MacBook Pro. It doesn’t even get to the login screen. The screen just stays black on boot.

It’s a 2015, i7, with onboard graphics (using i915 driver) and I suspect the graphics are the issue here but I don’t really know how to investigate this.

How can I get a log or some other indication of what is causing the problem?

Thank you!

reboot on version kernel 5.7 and stays
you should check in journal log

sudo journalctl -b -1 -p4 ( -b -1 boot before , -2  ... )

Super. I’ll try that after work and will report back

This is the log for that. Not sure how to find the actual issues in there. There are the ACPI errors in the beginning and then some Broadcom related errors, but I don’t know if any of those are actually the critical ones:

@lospompadores Did you get this resolved? I am having same issues on a 2013 iMac.

Unfortunately not. I googled the errors but haven’t found anything useful yet related to them. I’m not even sure those errors matter as not all items flagged up as error do. But it’s all I’ve got so I’ll keep searching.

@lospompadores I have been searching all over to no avail. Any kernel above 5.6 on any distro fails to boot. I will continue searching mate.

It’s been a head scratcher so far. I’ll definitely report back here if i ever get to the bottom of this

@lospompadores I was able to boot into 5.8 with adding this option to my grub config “intel_iommu=on”

1 Like

Superstar :sunglasses:

1 Like

Hi, i have your same macbook and i’m trying to install manjaro because i want to fix an sd card that i bought with f3.
I have your exact same problem, i cant boot ubuntu too.
I’m not an expert and i want to know if u can tell me where i have to put the option suggested by @jws141
I tried a couple of times but i without succes so i think i write it somewhere and is wrong.
I can’t find a guide anywhere… I plan also to permanently install it in dual boot if i can.

To set this permanently (e.g. when you’ve updated your kernel in an existing install) check out How to Update GRUB on Arch Linux – Linux Hint

To sum up:

sudo <your_editor_here> /etc/default/grub
add the intel_iommu=on bit to the …_LINUX_DEFAULT line in that file (then save and close)
then run: sudo grub-mkconfig -o /boot/grub/grub.cfg

If you just want to add this temporarily, for example, when booting a live image from a USB stick, on the boot screen, press “e” on the relevant option. That will show you the boot options. Just add the intel_iommu=on to the end of the line and then boot (that’s usually by pressing F10 or something)

I was able to boot it!
The problem was my usb drive 3.0, it’s not compatible (tried with dd command and with etcher). Instead it worked with a 2.0 one and adding the “intel_iommu=on” option (i tried only dd command for the usb installer).
Thank you also for the permanent tip!

I also want to ask you if there are any alternatives to the rEFInd bootloader or other methods to dual-boot manjaro with catalina.