Macbook pro 14,1 No Sound (Inxi Provided)

I installed manjaro gnome with 6.6 kernel onto my macbook pro 2017 14,1. I only have a dummy output in my sound options with no sound. I started with this kernal patch from GitHub - davidjo/snd_hda_macbookpro: Kernel audio driver for Macs with 8409 HDA chip + MAX98706/SSM3515 amps. I still had a dummy output with no sound. I tried fixing it by installing manjaro-pulse instead of using manjaro-pipewire. I then ran:

sudo systemctl --global disable --now pipewire.socket pipewire.service 


systemctl --user disable --now pipewire.socket pipewire.service

This is where I stopped playing with things.

I ran inxi --full --admin --filter --width

  Kernel: 6.6.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=4856b6c2-f6dc-48d1-98f3-4c2592dd6c29 rw quiet splash apparmor=1
    security=apparmor resume=UUID=3760d619-c1fb-455a-ba26-30d8a05ed061
  Desktop: GNOME v: 45.3 tk: GTK v: 3.24.39 wm: gnome-shell
    tools: gsd-screensaver-proxy dm: GDM v: 45.0.1 Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: Apple product: MacBookPro14,1 v: 1.0
    serial: <superuser required> Chassis: type: 9 v: Mac-B4831CEBD52A0C4C
    serial: <superuser required>
  Mobo: Apple model: Mac-B4831CEBD52A0C4C v: MacBookPro14,1
    serial: <superuser required> uuid: <superuser required> UEFI: Apple
    v: 522. date: 08/17/2023
  ID-1: BAT0 charge: 17.0 Wh (33.8%) condition: 50.3/54.6 Wh (92.0%)
    volts: 11.1 min: 11.4 model: SMP bq20z451 type: Li-ion serial: N/A
    status: discharging cycles: 137
  Info: model: Intel Core i5-7360U bits: 64 type: MT MCP arch: Amber/Kaby Lake
    note: check gen: core 7 level: v3 note: check built: 2017 process: Intel 14nm
    family: 6 model-id: 0x8E (142) stepping: 9 microcode: 0xF4
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 500 high: 600 min/max: 400/3600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 600 3: 600 4: 400
    bogomips: 18406
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: Intel Iris Plus Graphics 640 vendor: Apple driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:5926
    class-ID: 0300
  Display: wayland server: v: with: Xwayland v: 23.2.3
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: Apple Color LCD built: 2016 res: 2560x1600 dpi: 227
    gamma: 1.2 size: 286x179mm (11.26x7.05") diag: 337mm (13.3") ratio: 16:10
    modes: 2560x1600
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
    drv: iris inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.3-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Iris Plus Graphics 640
    (Kaby Lake GT3e) (KBL GT3) device-ID: 8086:5926 memory: 7.45 GiB
    unified: yes display-ID: :0.0
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:9d71
    class-ID: 0403
  Device-2: Broadcom 720p FaceTime HD Camera driver: N/A pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 14e4:1570 class-ID: 0480
  API: ALSA v: k6.6.10-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: off with: 1: wireplumber status: off
    2: pipewire-alsa type: plugin tools: pw-cat,pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active tools: pacat,pactl
  Device-1: Broadcom BCM4350 802.11ac Wireless Network Adapter vendor: Apple
    driver: brcmfmac v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 02:00.0 chip-ID: 14e4:43a3 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Local Storage: total: 113 GiB used: 13.11 GiB (11.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Apple model: SSD AP0128J
    size: 113 GiB block-size: physical: 4096 B logical: 4096 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 16.14.01 temp: 37.9 C
    scheme: GPT
  ID-2: /dev/nvme0n2 maj-min: 259:4 vendor: Apple model: SSD AP0128J
    C08850701LUHV52A0 size: 8 KiB block-size: physical: 4096 B logical: 4096 B
    speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter> fw-rev: 16.14.01
    temp: 38.9 C
  ID-1: / raw-size: 103.85 GiB size: 101.66 GiB (97.89%) used: 13.1 GiB (12.9%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.3 MiB (99.76%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 50.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 8 GiB available: 7.63 GiB used: 3.73 GiB (48.9%)
  Processes: 224 Power: uptime: 21m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform
    avail: shutdown,reboot,suspend,test_resume image: 3.04 GiB daemons: upowerd,
    power-profiles-daemon, gsd-power Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 1215 libs: 328 tools: gnome-software,pamac
    pm: flatpak pkgs: 0 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9
    running-in: gnome-terminal inxi: 3.3.32

I know enough to get me in trouble, so please excuse me if I made a mess. I can reinstall my OS if needed, not much is on this machine yet.

Edit: I apologize. This is a 14,1 not a 13,1. I have corrected the post and still require guidance.

Check this: Macbook 14 audio - #4 by anistorian
Or the essence of the thread: Macbook 14 audio - #57 by anistorian

EDIT: There is a fork of the driver mentioned above with added arch/manjaro support, so try this first since it will save you ‘Step 5: Changed script as per ishaanbhimwal’s instructions’.

I just did the following:

  1. I installed the 5.4 LTS Kernel.
  2. I rebooted and selected the 5.4 kernel
  3. ‘make’ ‘gcc’ and ‘wget’ are already installed
  4. I cloned the repo in question
  5. I modified the (the forked repo has not been updated in 3 years)
  6. I ran sudo ./

I now have an Analogue Stereo output, and two Analogue Surround outputs in my sound settings. The sound still does not work. I also tried reinstalling manjaro-pipewire, as the thread you shared involves the use of pipewire. This also did not produce sound. Should I try an OS reinstall and follow the instructions from scratch with no other variables?

I don’t think that’s necessary, just go step by step through the full thread and try to follow their steps.

EDIT: Maybe first install a newer kernel, 5.4 is very old. Probably won’t get your audio going but shouldn’t make it worse as long as you stick to LTS, like 6.1 or 6.6.

I’m silly and realized I missed a step. When I switched to the 5.4 kernel, I did not install the 5.4 header. You were right, starting from scratch did not help. Either way, following the instructions from scratch with the 5.4 header did not produce sound I will switch back to 6.6 as you suggest, install the 6.6 header, reinstall the driver, and try again.


  1. I booted into 6.6 Kernel
  2. Uninstalled 5.4 header
  3. Installed 6.6 header
  4. Reboot
  5. Ran modified as root
  6. Reboot

Back to Dummy output with no sound

Hang on a second, there’s something wrong here, maybe caused by the fact that there are actually more then 1 mbp 14,1. The above solution fixes a problem with a cirrus logic audio chip but your inxi shows Intel Sunrise.

And for that I get a much easier fix:

sudo pacman -Sy sof-firmware alsa-ucm-conf

Then create a file in /etc/modprobe.d/inteldsp.conf and put in:

options snd-intel-dspcfg dsp_driver=1

and reboot.
See here: [SOLVED] Sunrise Point-LP HD audio quit working after update / Multimedia and Games / Arch Linux Forums .

I had no idea there was more than one 14,1 :man_facepalming: freaking apple. I assumed that Intel Sunrise was an internal code name that included licensed cirrus logic audio technologies within the chipset. I followed your instructions:

  1. sudo pacman -Sy sof-firmware alsa-ucm-conf
  2. sudo nano /etc/modprobe.d/inteldsp.conf
  3. added options snd-intel-dspcfg dsp_driver=1
  4. Rebooted

Sorry, still no sound :frowning:

I would like to make a note that I did not choose to use this macbook :laughing: . I got it for free, repaired it, and just prefer manjaro.

I think you’re right here, it’s getting late…
Ok, reverse the above steps (maybe keep the sof-firmware) and install the up-to-date snd-hda-macbookpro-dkms-git from the AUR (needs headers).

Ok, I will uninstall als-ucm-conf, and delete /etc/modprobe.d/inteldsp.conf, and try snd-hda-macbookpro-dkms-git. I will edit the post with my results. It is getting late, don’t worry about getting this resolved tonight, I can come back :). Thanks for the help today.

EDIT: trying to uninstall in pamac als-ucm-conf gives me this new error:

could not satisfy dependencies:
- removing alsa-ucm-conf breaks dependency 'alsa-ucm-conf' required by alsa-lib

even though it was not needed prior to installation. I will try to get it removed and resolve the dependency issue. I will come back and add EDIT2 to this post.

EDIT2: I did another fresh reinstall. 6.6 kernel. Installed 6.6 headers. I discovered that alsa-ucm-conf actually is installed by default, and I cannot remove it because it is actually needed by alsa-lib. Installed dependencies. Cloned and made the package you recommended from the AUR. Installed using sudo pacman -U packagename. Rebooted. My system has slowed to a crawl. I can barely log in. When the desktop loads up, only the mouse moves, nothing else is responding. The sound icon is also visibly absent from the top bar. Posted from my phone.

EDIT3: Eventually my system snapped out of its thousand-yard stare. Sound is now working, but my sound icon is still missing. I will type these steps up correctly in the morning.


Well, good if sound is working. The snd-hda-macbookpro-dkms-git pkg could have been installed with pamac GUI (if you have the AUR enabled) or via:
pamac build snd-hda-macbookpro-dkms-git
it was meant as a smoother and more recent alternative to the ‘solution’ of the davidjo/github driver. Still, that doesn’t explain the slowdown.

Why this happened I don’t know; I’ve put manjaro on old 2008/9 mbp/imac and a 2017 macbook air and I now always start off by installing xfce minimal. I avoid KDE because it brought the graphics to its knees when later the system gets more decked out and the eye-candy options are used.

For the same reason I’ve never tried Gnome/wayland on these machines but I wonder if it’s the best option for your Intel Iris Plus, especially since it could handle xfce easily. If this is indeed the cause of the slowdown or why your pulse-audio icon doesn’t show I don’t know but on xfce this should be a speedy machine for regular tasks.

To get the icon do a search in the gnome section here, I think this might help: Volume keys and volume icon not working - #2 by axelinux .