Macbook 2.1 boot issues

Good night!

I’ve spent countless hours (should I say days? :smiling_face_with_tear:) trying to solve this, looking at tons of forum posts and wikis everywhere, including manjaro and archlinux websites, but it seems I am unable to solve it. I use manjaro on my main PC and I’d like to use in on this laptop, but it seems the 32-bit efi is making my life much harder. I’ll try to summarize my frustration:

  • tried both regular and manual manjaro installation, so it wouldnt automatically try to install grub. All changes and tweaks I’ve made to the installation where made with Manjaro live booted using ventoy ia32, by mounting the root volume and using manjaro-chroot to make changes.

  • as for grub, I tried installing both the one which comes with manjaro with target=i386-efi and another one I found somewhere, (bootia32.efi) with the version 2.04beta. With both I had partial sucess, as I was randomly able to boot, however, sometimes, after selecting the manjaro entry, it wouldn’t boot, leaving me with a black screen even before the “nosplash debug --verbose” options got to show up the booting log progressing. Also the computer had the fan silent, which makes me believe it just hanged. No idea on how to view any kind of log for this situation. I also tried grub after refind, with similar results;

  • I also tried to use systemd-boot, using its 32 bit efi version. After trying multiple configurations, the most success I had was by manually adding the loader entries, both with the boot files (vmlinuz, initramfs etc) both in the efi partition and in a xbootldr partition, both of them formated to fat32. In both situations I got an “Error loading \vmlinuz-6.6-x86_64: Unsupported”.

  • finally, as for refind, I created a manual stanza, as refind does not automatically find Manjaro without another bootloader such as grub or systemd-boot. After trying plenty configurations for the volume and loader, either by using the volume label, the partuuid, the guid unique uuid, and also trying a bunch of paths for the loader , I always got the same error “Invalid loader file! Not found while loading vmlinuz-6.6-x86_64”.

I am sorry for the long post. Thank you for you attention and patience! Have a good day

We had a tutorial around, or at least a long thread about it on one of the old forums …

Ah, found a tut here

Thank you for you attention. However, I already read that post, it describes how to boot a Manjaro installation ISO. However, that’s not the problem, as I can easily do that with ventoy .
The problem with the calamares installer is that it can’t install grub at the end. However, if I do a manual install of grubia32 using grub-install, the computer sometimes boot, sometimes doesn’t (black screen before the “Welcome to Manjaro Linux” message).

I will give a try to the linuxium script though.

If it’s only about getting it to boot have a look at this post about by @linux-aarhus: Getting Manjaro 64bit to boot on a 2007 iMac 7.1 with 32bit EFI - #8 by linux-aarhus . This also used to be the way to boot my imac 2006, so good luck.

Hi! So that I am sure I understood, the idea is to use refind to boot directly to vmlinuz? I tried that, altough unsuccessfully, because of the “Invalid loader file! Not found while loading vmlinuz-6.6-x86_64” error when I added a manual entry to refind.conf.
Just for reference, here’s my /dev/sda configuration:

- /dev/sda
  - sda1 # EFI
  - sda2 # MacOS
  - sda3 # Recovery HD
  - sda4 # unused
  - sda5 # /boot
  - sda6 # /swap
  - sda7 # /root

Any idea of what I might be doing wrong or any tip on how to do it?
Thank you!

It’s been along time, my 2006 32-bit efi imac died years ago. When I spotted the linked post above I remembered that I too needed refind to boot 32-bit efi macs and and I thought pointing this out might help you along.

I also remember to have to “bless” the 32bit grub efi, have a look here: [SOLVED] installing Arch on a 32 bit EFI MacBook / Installation / Arch Linux Forums .

1 Like

Do you remember if you booted using just refind of you used refind to load grub with which you’d boot manjaro?
Sorry, but still no progress. I’ve seen those links you sent in the past, though without the same attention I am giving them now. Still, to no avail :frowning:

Sorry, it’s been too long, I can’t remember.

However, pay attention to:

Warning: Starting with grub 2:2.06.r566.g857af0e17-1, GRUB’s i386-efi target is broken so it cannot be used to boot on IA32 UEFI. See FS#79098.

(This link also has a work-around/solution.)

UPDATE: We may have been making a big mistake here; according to MacBook "Core 2 Duo" 2.16 13" (White) Specs (Mid-2007, MB062LL/A, MacBook2,1, A1181, 2139): the efi architecture of macbook 2,1 is actually 64bit.

The actual limitation of getting it going is most likely the 4GB ram required to run manjaro. Even if yours is maxed out

it can hold 4GB but cannot fully utilize the memory beyond 3GB

Maybe give AntiX a try.

1 Like

First of all, thank you for all your tips!

But I have some questions:

  • I don’t know if this is very important, but I’ve been trying to run the cinnamon version;
  • actually, this is a 32-bit EFI, which I verified with cat /sys /firmware/efi/fw_platform_size. The everymac website is wrong;
  • when I boot from ventoy with the Cinnamom iso, it never fails to but and runs relatively well;
  • when I made a manual install, I had a much greater success in booting the installed system;
  • when I chroot and grub-install target=i386-efi --removable, the installed grub version is 2.06.r499;
  • if I follow the instructions you sent me, downloading and compiling the version 2.06 from, this version does not recognize the ext4 filesystem, even after insmod gzio, part_got and ext2. however the version from pacman does;
  • when successfully booted (using refind and grub), the system is quite snappy;
  • when it doesn’t boot, after adding the boot options “nosplash debug --verbose”, I get the boot logs of the photos attached to this post;
  • yet, after all of this, I was able to boot sometimes. Makes me think about why sometimes it boots, sometimes it doesn’t;
  • I still think the problem can be in any kind of configuration, as the system booted more frequently with the manual installation than with the automatic one;
  • I would like to try to boot the system with refind only (without grub), however I was unable to create a stanza that allows me to do it. I was focused on grub this entire day;
  • as for systemd-boot, it seems as the 64-bit booting on its 32bit version is an open issue as can be seen in these links:
    FS#79531 : [systemd] Package should provide EFI mixed mode support for systemd-boot on 32-bit UEFI systems

edit: btw, 4GB of memory is the recommended, not the minimum specs. I don’t see any reason on why wouldn’t it work with less, unless something (like Calamares, which is written in Python and needs around 3GB to not crash) wourld make it crash. / added another screenshot of the halted boot process, after 2795 sec.

Again, thank you!

I remember from my Linux Mint days that this is quite demanding on the graphics. For old hardware/low ram I use xfce/mate minimal or, if you can live without proper desktop environment, I3.

I think you’re right (first time that happened, it’s my go-to resource). Otherwise, why would there be all the arch forum links discussing booting 32bit efi?

There were discussions here regarding min ram requirements and it is indeed calamares that prevents some users to even install manjaro on <4GB machines. For me 4GB (usually minus some MB for built-in graphics, so ~3,7GB) is the minimum for a usable manjaro. I used, and setup for others, a number of systems mostly with xfce/mate, however, the no longer available Awesome edition provided by far the most responsive system on this kind of hardware. If you can live with a wm; I3 is in the same ballpark, so for a 3GB machine (and everymac is right here, my 2006 imac had 2x2GB but only 3GB available) this is what I’d try first (always download the ‘minimal’ iso).

I did some digging too with some interesting results like this script EFI-32 ISO erstellen – , however, this only works for arch iso. Another one is Linux DVD images (and how-to) for 32-bit EFI Macs (late 2006 models) | . I also wonder if Super Grub2 Disk Beta would be able to boot an installed manjaro.
Anyway, that’s my 2 cents spent here, I wish you good luck, if you succeed post a how-to.

As for the mattgradient ISOs, the ubuntu based ones work, install and boot the installed OS. However, the Manjaro one does not boot. I believe it’s the same problem. As for the EFI-32 ISO erstellen, the script does not work. I believe it’s old, it doesn’t even accept manjaro iso and can’t find some files within the archlinuxiso: “/efi32iso/newiso/loader/entries/archiso-x86_64-linux.conf’ for reading: No such file or directory”.
As for Super Grub 2, it also shares that same problem of not recognizing ext4 partitions.
Seems no solution is on sight, even though there are solutions for other distros such as ubuntu and derivatives.

Thanks for your time nonetheless!

I believe the only way this could be solved is if the systemd-boot project creates an universal solution which will work in the future. Sadly, the BIOS only PCs are better covered. However, there is little incentive, as this kind of machines were produced only between 2006-2010 and some atom processor tablets and such. It’s sad, as I could guarantee that Manjaro could still browse the web in a very acceptable way on a 64MB VRAM iGPU from 17 years ago.