Macbook 14 audio


Just installed Manjaro on my Macbook 14,1 yesterday, with the same issues concerning audio and bluetooth.

The only solution that I have found for the sound, that might work is this: GitHub - davidjo/snd_hda_macbookpro: Kernel audio driver for Macs with 8409 HDA chip + MAX98706/SSM3515 amps

I am at work right now, so haven’t had a chance to try it out yet. Will let you know how it works out.

I couldn’t get it working for Manjaro unfortunately, but did manage to install the driver on Linux Mint and sound does work.

When trying to install it on Manjaro it says I don’t have the headers I need. Haven’t been able to figure out what exactly it means yet, but assume it is something with the kernel version.

I will try to see if I can get it to work and keep you updated.

may you post the output of ‘uname -a’ from your manjaro to understand what kernel you are using and it’s far better to give us information to help .
this is mandatory :slight_smile:

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.
P.P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which exact CPU/GPU or Kernel, … you have without typing it every time

1 Like

Hi Olli

Thank you very much for taking the time to help out :slight_smile:

So I am back on Manjaro now - profile is updated with relevant info and the outputs of uname -r and inxi can be found in the end of the post.

So what I have done is that I tried to install the driver as described here on Linux Mint 20.3. It worked as well as the author described, but at least now I know that it can work.

On Manjaro I have installed the 5.4 kernel, chosen it from the GRUB menu and installed the headers for 5.4.

Now when I try to install the driver I get this output:

linux kernel headers not found in /usr/src:
Debian (eg Ubuntu): /usr/src/linux-headers-5.4.173-1-MANJARO
Fedora: /usr/src/kernels/5.4.173-1-MANJARO
assuming the linux kernel headers package is not installed
please install the appropriate linux kernel headers package:
sudo apt install linux-headers-MANJARO

When looking the /usr/src it is empty, so I guess that is why the script will not install it. Then the problem is, where are the header files located in Manjaro? Further should the install script be changed to reflect the new location? Or can we create a symlink to the correct location from /usr/src? Or I am missing something very basic?

Hope you can help out :slight_smile:

uname -r:



  Kernel: 5.4.173-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64
    root=UUID=6f7d5ee1-e56e-411c-93c8-39dbb7a74835 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Apple product: MacBookPro14,1 v: 1.0
    serial: <superuser required> Chassis: type: 9 v: Mac-B4831CEBD52A0C4C
    serial: <superuser required>
  Mobo: Apple model: Mac-B4831CEBD52A0C4C v: MacBookPro14,1
    serial: <superuser required> UEFI: Apple v: 447. date: 09/25/2021
  ID-1: BAT0 charge: 18.3 Wh (48.8%) condition: 37.5/54.6 Wh (68.7%)
    volts: 11.0 min: 11.4 model: DSY bq20z451 type: Li-ion serial: N/A
    status: Discharging cycles: 379
  RAM: total: 7.64 GiB used: 1.81 GiB (23.7%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-7360U bits: 64 type: MT MCP arch: Amber/Kaby Lake
    note: check family: 6 model-id: 0x8E (142) stepping: 9 microcode: 0xEA
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 844 high: 1276 min/max: 400/3600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 700 2: 700 3: 700 4: 1276
    bogomips: 18406
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
    art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
    f16c flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp
    hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good rtm sdbg sep
    smap smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
    tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic
    xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: Split huge pages
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
  Device-1: Intel Iris Plus Graphics 640 vendor: Apple driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:5926 class-ID: 0300
  Display: x11 server: compositor: kwin_x11 driver:
    loaded: modesetting alternate: fbdev,vesa resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
  Device-2: Broadcom 720p FaceTime HD Camera driver: N/A bus-ID: 03:00.0
    chip-ID: 14e4:1570 class-ID: 0480
  Sound Server-1: ALSA v: k5.4.173-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Broadcom BCM4350 802.11ac Wireless Network Adapter vendor: Apple
    driver: brcmfmac v: kernel bus-ID: 02:00.0 chip-ID: 14e4:43a3 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 113 GiB used: 21.25 GiB (18.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Apple model: SSD SM0128L
    size: 113 GiB block-size: physical: 4096 B logical: 4096 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: CXS4LA0Q scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 112.65 GiB size: 110.32 GiB (97.93%)
    used: 21.25 GiB (19.3%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: 6f7d5ee1-e56e-411c-93c8-39dbb7a74835
  ID-2: /boot/efi raw-size: 300 MiB size: 299.3 MiB (99.76%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: NO_LABEL uuid: F8C3-9E8A
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 31.7 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 173 Uptime: 40m wakeups: 5 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1213 lib: 332
  flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.12

may you post the output of ‘hwinfo --sound’ and is there a reason not to update to the latest kernel ?

Oh, sorry, I forgot to put in the link to the driver on github.

It is here: GitHub - davidjo/snd_hda_macbookpro: Kernel audio driver for Macs with 8409 HDA chip + MAX98706/SSM3515 amps

And the driver doesn’t work in kernels later than 5.5 or possibly 5.6. But since the 5.4 had a LTS, I went for that. If you cna make it work on 5.16 I am totally up for that as well haha.

hwinfo --sound:

18: PCI 1f.3: 0403 Audio device                                 
  [Created at pci.386]
  Unique ID: nS1_.W+AMVqUgGp9
  SysFS ID: /devices/pci0000:00/0000:00:1f.3
  SysFS BusID: 0000:00:1f.3
  Hardware Class: sound
  Model: "Intel Sunrise Point-LP HD Audio"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x9d71 "Sunrise Point-LP HD Audio"
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x7270 
  Revision: 0x21
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0x92820000-0x92823fff (rw,non-prefetchable)
  Memory Range: 0x4000000000-0x400000ffff (rw,non-prefetchable)
  IRQ: 56 (481 events)
  Module Alias: "pci:v00008086d00009D71sv00008086sd00007270bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Driver Info #1:
    Driver Status: snd_soc_skl is active
    Driver Activation Cmd: "modprobe snd_soc_skl"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

please post the output of ‘sudo dmesg | grep snd’ and may you start a terminal and run alsamixer. what is the output ?

sudo dmesg | grep snd:

[    3.187376] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    3.271256] snd_hda_codec_generic hdaudioC0D0: autoconfig for Generic: line_outs=2 (0x24/0x25/0x0/0x0/0x0) type:speaker
[    3.271260] snd_hda_codec_generic hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    3.271262] snd_hda_codec_generic hdaudioC0D0:    hp_outs=1 (0x2c/0x0/0x0/0x0/0x0)
[    3.271264] snd_hda_codec_generic hdaudioC0D0:    mono: mono_out=0x0
[    3.271265] snd_hda_codec_generic hdaudioC0D0:    inputs:
[    3.271267] snd_hda_codec_generic hdaudioC0D0:      Internal Mic=0x44
[    3.271269] snd_hda_codec_generic hdaudioC0D0:      Mic=0x3c

And the alsamixer shows the same as yours, but when I try to add the image of alsamixer it lets me know I cannot integrate media :confused:

are you sure at alsamixer, please open it again and press “m”-key. does it change to “mm” (muted) or was it muted ? make sure that there is no “mm” for muting at alsamixer.
did you install “pavucontrol” from the software-center?

It does change to ‘mm’ when pressing the m-key, and it was not muted before.

I have not installed pavucontrol. Should I install it ?

yes, please install it and make sure that alsamixer doesn’t mute the output. if you’ve installed pavucontrol we’ll check this. seems your driver is working because it accepts changes at alsamixer but propably your output-device isn’t set properly. this can be adjusted with pavucontrol.
there is also some weird, alsa and pipewire is active. some had trouble but others didn’t.

Should it be the pavucontrol or pavucontrol-qt package ?

there should be a “pavucontrol” at the control center. this should be the preferred. you’re running kde, that should also work with qt but if there is a simple “pavucontrol” then try this first.

It is installed :slight_smile:

may you start it ? give me a second.
if you started pavucontrol, please open the configuration and check what outputs are avaiable.

if you open the configuration, what is avaiable ?

This is what I get:

okay that should be working as long as you use the internal speakers or the headphone-jack.
what is set at the output-devices ?

is there a sound-symbol at your bar (in the right-bottom corner) ?