M4a audio file format does not play in VLC or lollypop player

Hi All,
I have few audio files that have the extension m4a and I cannot play them in VLC or Lollypop player in Manjaro.

Software version using:
Manjaro - Uranos 23.0, Gnome - 44.5, Kernel - Linux 6.1.55-1-MANJARO

When I run the m4a file in terminal, here is the output.

~/Audio $ vlc 2023-11-01-11-31-33.m4a
VLC media player 3.0.18 Vetinari (revision 3.0.13-8-g41878ff4f2)
[000056240b5f2550] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7f47b0c6e980] moov atom not found
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7f4764c08100] moov atom not found
[00007f47640011a0] avformat demux error: Could not open /home/lx/Audio/2023-11-01-11-31-33.m4a: Unknown error 1094995529

Please let me know, if I had to install some codecs to make it work.

Thank you!

They are mpeg4 audio files, so basically the audio of a video, mainly put out by apple devices. VLC should play them, set Video output at Tools >> Preferences >> Video >> Output modules to ‘X11 video output’ and hit ‘Save’.

I actually convert those files because this file format is not accepted in sound editing software. There is the dead simple SoundConverter app in the repos; set the converter output to mp3, pull all m4a files in the converter window, hit ‘convert’ and delete the m4a, takes maybe 2 seconds for a dozen files.

1 Like

Hi @6x12 ,

Thank you for pointing me in the right direction and narrowing down the issue.
SoundConverter app also worked like a charm :+1:.

Really appreciate your help!

After reading your post, I just realized:

  • The issue is with the 3rd party app - Audio Recorder that created a recording in the format m4a, has an issue (Note: Other formats created by Audio Recorder are working fine except m4a).
  • The m4a audio files that were not created by Audio recording (Ex - m4a files created in mac) are working/playing fine in Manjaro Linux without any changes in VLC Player (defaults settings).

Any way to fix the issue with Audio Recording created output - audio file format m4a ? May be some codecs are missing for the App to work properly for m4a?

Here is the Audio-recorder App version that was already installed.

$ yay -Ss audio-recorder                   
aur/audio-recorder 3.3.4-1 (+61 0.87) (Installed)
    Audio Recorder Application

Please suggest.

Set AudioRecorder output to mp3 and wait 'till an upgrade fixes thee issue.

I would try opening SoundConverter, hit settings, select ‘Same folder as the input file’ with 'Delete Original File UNCHECKED.

Then lower down ‘Opus’ at ‘Insanely High’ Quality which (~192kbps) is more than transparent - then see if that works.

However, I just tested it out via microphone and it seems to generate m4a files which are playable in Deadbeef and Audacious.

I suggest using another audio recorder that is not 2 years out of date, or ‘maintained’ on launchpad.net. Even if someone reports this bug upstream, users may have a long wait for a working version to be released

I use Audacity and Ocenaudio for recording/editing audio and both support creation of m4a files

But if there are only a few m4a files, it may be easier to convert them to mp3

ffmpeg -i 'file name.m4a' -acodec libmp3lame -b:a 192k 'file name.mp3'
1 Like

Hi @6x12,
Yeah, will have to wait and see if the App developer fixes the issue, will try to create a bug report.

@Ben, May be, in my case, the m4a audio file itself is corrupted and can’t be converted. I have tried your suggestion as well.

I was really looking for simple audio recording tool, much similar to Quick Time player in mac, heard a lot about Audacity on the Linux blogs but I really liked Ocenaudio for it being simple, Thank you for your suggestion.

Audio Recorder App
The m4a audio files that were generated by AudioRecorder cant be played at all, in any player, lost all the files that were generated.

When trying to convert using SoundConverter App, generated by Audio Recorder m4a file. I get the below error pop up

The specified file is not supported.
Either because it is broken or not an audio file

Thank you for all the help @6x12, @nikgnomic, @Ben

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.