Lzma library error: Corrupted input data

i686

#1

Update fails:

# pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
warning: vlc: ignoring package upgrade (2.2.8-4.0 => 3.0.2-1.0)
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: phonon-qt4-vlc will be installed before its phonon-qt4 dependency

Packages (192) accountsservice-0.6.49-1.0  acpid-2.0.29-2.0
               alsa-plugins-1.1.6-2.0  appstream-glib-0.7.7-1.0
               archlinux-appstream-data-20180424-1.0
               archlinux32-keyring-20180411-1.1  audacious-plugins-3.9-3.0
               babl-0.1.50-1.0  binutils-2.30-4.1  bluegriffon-3.1-1.0
               blueman-2.0.5-2.0  bluez-5.49-4.0  bluez-libs-5.49-4.0
               brotli-1.0.4-1.0  btrfs-progs-4.16-2.0
               ca-certificates-mozilla-3.37-1.0  chromaprint-1.4.3-2.0
               colord-1.4.3-1.0  crda-4.14-1.1  cryptsetup-2.0.3-1.0
               cups-filters-1.20.3-2.0  curl-7.60.0-1.0  dbus-1.12.8-1.0
               dhcpcd-7.0.4-1.0  e2fsprogs-1.44.2-1.0  ffmpeg-1:4.0-2.2
               ffmpegthumbnailer-2.2.0-2.0  file-5.33-1.1  filesystem-2018.1-3
               freetype2-2.9.1-1.0  fuse-common-3.2.3-1.0  gcc-8.1.0-1.1
               gcc-libs-8.1.0-1.1  gconf-3.2.6+11+g07808097-3.0  gcr-3.28.0-3.0
               gegl-0.4.2-1.0  gimp-2.10.2-1.0  glib-networking-2.56.1-1.0
               glibc-2.27-3.1  gnome-keyring-1:3.28.2-1.0  gnupg-2.2.7-1.0
               gobject-introspection-runtime-1.56.1-1.0  gpgme-1.11.1-1.0
               gsm-1.0.18-1.0  gst-libav-1.14.1-1.0
               gst-plugins-base-1.14.1-1.0  gst-plugins-base-libs-1.14.1-1.0
               gst-plugins-ugly-1.14.1-1.0  gstreamer-1.14.1-1.0
               gvfs-1.36.2-1.0  gvfs-afc-1.36.2-1.0  gvfs-gphoto2-1.36.2-1.0
               gvfs-mtp-1.36.2-1.0  gvfs-nfs-1.36.2-1.0  gvfs-smb-1.36.2-1.0
               hplip-3.18.4-2.0  ilmbase-2.2.1-2.0  imagemagick-7.0.7.32-1.0
               intel-ucode-20180425-1.0  inxi-3.0.08-1  js52-52.7.3-2.0
               kauth-5.46.0-1.0  kcoreaddons-5.46.0-1.0  kitemmodels-5.46.0-1.0
               krb5-1.16.1-1.0  ldb-1.3.2-1.0  libaio-0.3.111-1.0
               libblockdev-2.17-3.0  libbytesize-1.2-1.0  libdrm-2.4.92-1.0
               libdvdcss-1.4.2-1.0  libebml-1.3.6-1.0  libepoxy-1.5.2-1.0
               libetonyek-0.1.8-1.0  libgexiv2-0.10.8-1.0  libgme-0.6.2-1.0
               libgpg-error-1.31-1.0  libgphoto2-2.5.18-1.0  libgsf-1.14.43-1.0
               libibus-1.5.18-1.0  libidn-1.34-2.0  libinput-1.10.7-1.0
               liblouis-3.5.0-1.0  libmagick-7.0.7.32-1.0
               libmatroska-1.4.9-1.0  libmwaw-0.3.14-1.0  libmypaint-1.3.0-5.0
               libnetfilter_conntrack-1.0.7-1.0  libnghttp2-1.31.1-1.0
               libnm-1.10.8-1.0  libnm-glib-1.10.8-1.0  libnsl-1.2.0-1.0
               libpsl-0.20.2-1.0  libreoffice-still-5.4.6-2.0
               librsvg-2:2.42.4-1.0  libsoup-2.62.2-1.0  libsrtp-1:2.2.0-1.0
               libsynctex-2017.44590-14.0  libtirpc-1.0.3-2.0
               libtool-2.4.6+40+g6ca5e224-6.0  libva-mesa-driver-18.0.4-1.0
               libwbclient-4.8.1-1.1  libwebp-1.0.0-1.0  libwps-0.4.9-1.0
               libx264-2:152.20171224-2.1  libx264-all-2:152.20171224-2.1
               libzip-1.5.1-1.0  linux-api-headers-4.16.1-1.0
               linux-firmware-20180507.8fc2d4e-1  linux414-4.14.42-1
               llvm-libs-6.0.0-4.1  lm_sensors-3.4.0-3.0  man-pages-4.16-1.0
               manjaro-browser-settings-20180523-1  manjaro-hello-0.5.11-2
               manjaro-xfce-settings-20180505-1  mesa-18.0.4-1.0
               mesa-vdpau-18.0.4-1.0  mhwd-0.6.3-1  mhwd-db-0.6.3-1
               mhwd-nvidia-390xx-390.59-1  mypaint-brushes-1.3.0-2.0
               nano-2.9.7-1.0  ndctl-60.3-1.0  net-snmp-5.7.3-8.0
               networkmanager-1.10.8-1.0  nss-3.37-1.0  ntp-4.2.8.p11-2.0
               openal-1.18.2-2.0  openvpn-2.4.6-1.0  pacman-mirrors-4.10.1-3
               pam-1.3.0-2.0  pamac-6.3.1-1  pcsclite-1.8.23-3.0
               perl-5.26.2-1.0  perl-uri-1.74-1.0  phonon-qt4-4.10.1-1.0
               phonon-qt4-vlc-0.10.1-2.0  phonon-qt5-4.10.1-1.0  php-7.2.5-2.0
               php-apache-7.2.5-2.0  php-sqlite-7.2.5-2.0  pinentry-1.1.0-3.0
               poppler-0.64.0-1.0  poppler-data-0.4.9-1.0
               poppler-glib-0.64.0-1.0  poppler-qt5-0.64.0-1.0
               procps-ng-3.3.15-1.0  python-3.6.5-3.0  python-cairo-1.17.0-1.0
               python-jade-application-kit-1.3.5-1  python-packaging-17.1-1.0
               python-setuptools-1:39.2.0-1.0  python-xdg-0.26-1.0
               python2-2.7.15-1.0  python2-cairo-1.17.0-1.0
               qt5-base-5.10.1-8.0  qt5-declarative-5.10.1-4.0  samba-4.8.1-1.1
               smbclient-4.8.1-1.1  spectre-meltdown-checker-0.37-1
               srt-1.3.0-2.0  tcl-8.6.8-3.0  thin-provisioning-tools-0.7.6-1.0
               tslib-1.16-1.0  tzdata-2018e-1.0  unrar-1:5.6.4-1.0
               vertex-maia-themes-20180429-1  vte-common-0.52.2-1.0
               vte3-0.52.2-1.0  vulkan-icd-loader-1.1.73.0-1.0
               vulkan-intel-18.0.4-1.0  vulkan-radeon-18.0.4-1.0
               wayland-1.15.0-1.1  wayland-protocols-1.14-1.0
               webkit2gtk-2.20.2-1.0  wget-1.19.5-1.0  xdg-utils-1.1.3-1.0
               xf86-video-amdgpu-18.0.1-2.0  xf86-video-ati-1:18.0.1-2.01
               xf86-video-intel-1:2.99.917+831+ge7bfc906-1.0
               xf86-video-nouveau-1.0.15-3.0  xfce4-cpufreq-plugin-1.2.0-1.0
               xfce4-pulseaudio-plugin-0.4.1-1.1  xfce4-screenshooter-1.9.2-1.0
               xfce4-sensors-plugin-1.3.0-1.0  xfce4-terminal-0.8.7.4-1.0
               xfce4-whiskermenu-plugin-2.2.0-1.0  xkeyboard-config-2.23.1-3.0
               xorg-server-1.20.0-2.0  xorg-server-common-1.20.0-2.0
               xz-5.2.4-1.0

Total Installed Size:  2545.37 MiB
Net Upgrade Size:        89.37 MiB

:: Proceed with installation? [Y/n] y
(192/192) checking keys in keyring                 [######################] 100%
(192/192) checking package integrity               [######################] 100%
(192/192) loading package files                    [######################] 100%
(192/192) checking for file conflicts              [######################] 100%
(192/192) checking available disk space            [######################] 100%
warning: could not get file information for usr/lib/libreoffice/presets/basic/Standard/Module1.xba
warning: could not get file information for usr/lib/libreoffice/presets/basic/Standard/dialog.xlb
warning: could not get file information for usr/lib/libreoffice/presets/basic/Standard/script.xlb
warning: could not get file information for usr/lib/libreoffice/presets/gallery/sg30.sdv
warning: could not get file information for usr/lib/libreoffice/presets/gallery/sg30.thm
warning: could not get file information for usr/lib/firefox/distribution/
:: Processing package changes...
(  1/192) upgrading linux-api-headers              [######################] 100%
(  2/192) upgrading tzdata                         [######################] 100%
(  3/192) upgrading filesystem                     [######################] 100%
warning: /etc/fstab installed as /etc/fstab.pacnew
warning: /etc/group installed as /etc/group.pacnew
warning: /etc/hosts installed as /etc/hosts.pacnew
warning: /etc/passwd installed as /etc/passwd.pacnew
warning: /etc/resolv.conf installed as /etc/resolv.conf.pacnew
warning: /etc/shells installed as /etc/shells.pacnew
warning: /etc/gshadow installed as /etc/gshadow.pacnew
warning: /etc/shadow installed as /etc/shadow.pacnew
warning: /etc/crypttab installed as /etc/crypttab.pacnew
(  4/192) upgrading glibc                          [######################] 100%
warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
Generating locales...
  en_CA.UTF-8... done
  en_US.UTF-8... done
Generation complete.
(  5/192) upgrading gcc-libs                       [######################] 100%
(  6/192) upgrading e2fsprogs                      [######################] 100%
(  7/192) upgrading perl                           [######################] 100%
(  8/192) upgrading krb5                           [######################] 100%
(  9/192) upgrading libtirpc                       [######################] 100%
( 10/192) upgrading pam                            [######################] 100%
( 11/192) upgrading js52                           [######################] 100%
( 12/192) upgrading xz                             [######################] 100%
( 13/192) upgrading libgpg-error                   [######################] 100%
( 14/192) upgrading dbus                           [######################] 100%
( 15/192) upgrading cryptsetup                     [######################] 100%
( 16/192) upgrading libidn                         [######################] 100%
( 17/192) upgrading accountsservice                [######################] 100%
( 18/192) upgrading acpid                          [######################] 100%
( 19/192) upgrading alsa-plugins                   [######################] 100%
( 20/192) upgrading ca-certificates-mozilla        [######################] 100%
( 21/192) upgrading glib-networking                [######################] 100%
( 22/192) upgrading libsoup                        [######################] 100%
( 23/192) upgrading colord                         [######################] 100%
( 24/192) upgrading freetype2                      [######################] 100%
( 25/192) upgrading librsvg                        [######################] 100%
( 26/192) upgrading libdrm                         [######################] 100%
( 27/192) upgrading wayland                        [######################] 100%
( 28/192) upgrading llvm-libs                      [######################] 100%
( 29/192) upgrading lm_sensors                     [######################] 100%
( 30/192) upgrading mesa                           [######################] 100%
error: could not extract /usr/lib/dri/nouveau_vieux_dri.so (Lzma library error: Corrupted input data)
error: problem occurred while upgrading mesa
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occurred, no packages were upgraded.
# 

[Testing Update x32] 2018-05-17 to 26 - Xorg 1.20, GCC 8.1.0, rebuilds, kernels, NVIDIA EOL
#2

This probably means the package file itself is corrupted in some way. Can you delete it from disk and try again?

Another possibility is that the XZ file format changed… but that’s more unlikely.


#3

Deleted the mesa package and then had to delete existing files before the update completed.


split this topic #4

3 posts were merged into an existing topic: Can’t log in via graphical login manager


closed #5

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.