Lutris wont install Origin

Hi, I tried to install Origin. It worked well when I used the integrated GPU.
But that isn’t good for gaming.
So, I switched to the discret Nvidia GPU.
In this case the install crashes. I can see this messages in the window of the install process:

Started initial process 4921 from /home/molnari/.local/share/lutris/runners/wine/lutris-fshack-6.21-6-x86_64/bin/wine /home/molnari/.cache/lutris/installer/origin/client/OriginSetup.exe /silent
Start monitoring process.
0138:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0066EBFC 1 C) semi-stub
0138:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0066E9EC 1 C) semi-stub
0138:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0066E9FC 1 C) semi-stub
0138:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0066EC3C 1 C) semi-stub
0138:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0066EAFC 1 C) semi-stub
0138:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0066EAAC 1 C) semi-stub
0140:err:kerberos:kerberos_LsaApInitializePackage no Kerberos support, expect problems
0140:fixme:d3d:wined3d_guess_card No card selector available for card vendor 0000 (using GL_RENDERER "llvmpipe (LLVM 13.0.0, 256 bits)").
wine: Unhandled page fault on execute access to 00000000 at address 00000000 (thread 0140), starting debugger...
0148:fixme:imm:ImeSetActiveContext (0xb60030, 1): stub
0148:fixme:imm:ImmReleaseContext (000100C0, 00B60030): stub
0154:fixme:imm:ImeSetActiveContext (0x4403d0, 0): stub
0154:fixme:imm:ImmReleaseContext (0000000000010082, 00000000004403D0): stub

What should fix in my system?

It appears it can’t find the driver as it’s falling babck to llvmpipe.

Please post your system info as outlined here:

Which post contains the correct format of providing information in that topic?

inxi --admin --verbosity=7 --filter --width
  Kernel: 5.10.89-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=9a3969dc-0c4f-4c8a-9c7f-4e8cd555f435 rw quiet
  Desktop: Cinnamon 5.0.7 tk: GTK 3.24.31 vt: 7 dm: LightDM 1.30.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Micro-Star product: GF63 Thin 10SCXR v: REV:1.0
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Micro-Star model: MS-16R4 v: REV:1.0 serial: <superuser required>
    UEFI: American Megatrends v: E16R4IMS.105 date: 04/17/2020
  ID-1: BAT1 charge: 47.3 Wh (100.0%) condition: 47.3/51.3 Wh (92.1%)
    volts: 12.7 min: 11.4 model: MSI Corp. MS-16R4 type: Li-ion serial: N/A
    status: Full
  RAM: total: 31.18 GiB used: 2.81 GiB (9.0%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
    family: 6 model-id: 0xA5 (165) stepping: 2 microcode: 0xEA
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 800 min/max: 800/5000 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 9: 800 10: 800 11: 800 12: 800 bogomips: 62431
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr
    ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq
    pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdrand rdseed
    rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3
    stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx
    vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Micro-Star MSI
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300
  Device-2: NVIDIA TU117M vendor: Micro-Star MSI driver: nvidia v: 495.44
    alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f99
    class-ID: 0302
  Display: x11 server: X.Org driver: loaded: modesetting,nvidia
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x318mm (20.0x12.5")
    s-diag: 599mm (23.6")
  Monitor-1: HDMI-1-1 res: 1920x1200 hz: 60 dpi: 94
    size: 518x324mm (20.4x12.8") diag: 611mm (24.1")
  OpenGL: renderer: NVIDIA GeForce GTX 1650 with Max-Q Design/PCIe/SSE2
    v: 4.6.0 NVIDIA 495.44 direct render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci
    bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
  Device-2: Corsair VOID ELITE USB Gaming Headset type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-5:4 chip-ID: 1b1c:0a52
    class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.10.89-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.42 running: no
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel port: 3000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:5 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.38 TiB used: 165.69 GiB (11.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston
    model: RBUSNS8154P3512GJ5 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
    rev: E8FK12.D temp: 40.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM048-2E7172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 0001 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 238.42 GiB size: 233.68 GiB (98.01%)
    used: 37.93 GiB (16.2%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 9a3969dc-0c4f-4c8a-9c7f-4e8cd555f435
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: FF3C-41DF
  ID-3: /mnt/misc_disk raw-size: 684 GiB size: 672.26 GiB (98.28%)
    used: 127.76 GiB (19.0%) fs: ext4 dev: /dev/sda4 maj-min: 8:4 label: misc
    uuid: f417ae0c-6b9f-45d7-affb-827b6ad26286
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: 42569afe-0e3a-49ef-9c01-93d866fdac4a
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 300 MiB fs: vfat label: N/A
    uuid: D5C5-9B1E
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 467.84 GiB fs: ext4 label: N/A
    uuid: 60356ee5-c51e-460f-bb14-cb1ef46c6b36
  ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 8.8 GiB fs: swap label: N/A
    uuid: de013c32-62fb-47e9-a4a6-2374f3b01231
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: Logitech M105 Optical Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 100mA chip-ID: 046d:c077 class-ID: 0301
  Device-2: 1-4:3 info: Logitech Keyboard K120 type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 90mA chip-ID: 046d:c31c class-ID: 0300
  Device-3: 1-5:4 info: Corsair VOID ELITE USB Gaming Headset
    type: Audio,HID driver: hid-generic,snd-usb-audio,usbhid interfaces: 4
    rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 1b1c:0a52 class-ID: 0300
    serial: <filter>
  Device-4: 1-14:5 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 8 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 43.0 C pch: 48.0 C mobo: N/A gpu: nvidia
    temp: 42 C
  Fan Speeds (RPM): N/A
  Processes: 307 Uptime: 56m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1352 pacman: 1345 lib: 478
  flatpak: 0 snap: 7 Shell: Bash v: 5.1.12 running-in: gnome-terminal
  inxi: 3.3.12

By doing what? Do you have the option to use discrete graphics enabled in Lutris Preferences under Global Options?

I am using the optimus-manager utility to switching between integrated and nvidia gpus.
The Lutris Preferences has no option, there is only one the: Off.

The Use discrete graphics option is a toggle. It will be grayed out if it’s not available. It sounds like you’re looking at the Optimus Launcher option.

You are right.
By the way, the discrete graphics option toggle is On state.

Do you have more advise in this subject?

The next release of Lutris will include by default support for origin and Ubisoft connect.
Sorry not to help a lot (my knowledge of this is very limited) but maybe in the next version this gets fixed for you?
Hope you find a proper solution in the mean time anyway, just thought you’d like to know.

Thanks for the info. That next release could help me.

Good news! A lesser miracle happened.
I installed on another drive a completely new system from the scratch.
I was able install Lutris and inside that the Origin.
One strange thing. I can’t see any vulkan related things in the Lutris/Preferences/Global Options.
It would be nice to know, what is in the background. Maybe I could improve something or make better.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.