Lutris shows "not an lzma file" error when launching it/game, how to fix?

I suddenly started to have problems with Lutris, where it throws an error “not an lzma file” when I’m launching it(but it launches) and next when I’m trying to run a game(games won’t launch).

I tried to reinstall Lutris, while removing all files that it lefts(./local and ./cache at least), but it didn’t solve the problem.

Any ideas?

Just in case my system:

  Kernel: 6.1.19-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.1-x86_64
    root=UUID=ffa12ac7-57a4-4fc1-8712-bd5c5c1bb68e rw rootflags=subvol=@
    quiet splash udev.log_priority=3
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Acer product: Swift SF314-43 v: V1.04
    serial: <superuser required>
  Mobo: LN model: Sake_CA v: V1.04 serial: <superuser required> UEFI: Insyde
    v: 1.04 date: 07/28/2021
  ID-1: BAT1 charge: 39.7 Wh (79.6%) condition: 49.9/53.2 Wh (93.7%)
    volts: 12.3 min: 11.6 model: COSMX AP20CBL type: Li-ion serial: <filter>
    status: not charging
  Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
    process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x68 (104) stepping: 1
    microcode: 0x8608102
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1530 high: 2001 min/max: 1400/4056 boost: enabled
    scaling: driver: acpi-cpufreq governor: ondemand cores: 1: 1238 2: 1577
    3: 1772 4: 1700 5: 1596 6: 2001 7: 1437 8: 1388 9: 1216 10: 1313 11: 1490
    12: 1635 bogomips: 50328
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Lucienne vendor: Acer Incorporated ALI driver: amdgpu
    v: kernel arch: GCN-5 code: Vega process: GF 14nm built: 2017-20 pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:164c
    class-ID: 0300 temp: 43.0 C
  Device-2: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-3:2
    chip-ID: 0408:a094 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0x683d built: 2019
    res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85")
    diag: 355mm (14") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.3.5 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.49 6.1.19-1-MANJARO) direct-render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio
    vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1
    chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
    vendor: Acer Incorporated ALI driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_rpl_pci_acp6x,snd_pci_ps,snd_sof_amd_renoir,snd_sof_amd_rembrandt
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound API: ALSA v: k6.1.19-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: Lite-On driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 01:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  Device-1: Lite-On Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 04ca:3802 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 261.73 GiB (54.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PDP3512B-AA1
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: EDFK0S03 temp: 46.9 C scheme: GPT
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 261.73 GiB (54.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 261.73 GiB (54.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 261.73 GiB (54.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 20 GiB used: 0 KiB (0.0%) priority: -2
    file: /swap/swapfile
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: amdgpu temp: 45.0 C
  Fan Speeds (RPM): N/A
  Processes: 339 Uptime: 13m wakeups: 1595 Memory: 14.98 GiB
  used: 4.83 GiB (32.2%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1464 libs: 465 tools: pamac Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: yakuake inxi: 3.3.25

Please post the full output running lutris from the terminal.

What game(s) are you having issues with?

2023-03-18 20:42:30,618: Starting Lutris 0.5.13
2023-03-18 20:42:30,748: Running AMD Mesa driver 22.3.5 on AMD Radeon Graphics (renoir, LLVM 15.0.7, DRM 3.49, 6.1.19-1-MANJARO) (0x164c)
2023-03-18 20:42:30,748: GPU: 1002:164C 1025:1537 (amdgpu drivers)
2023-03-18 20:42:30,878: Running migration: mess_to_mame
2023-03-18 20:42:30,880: Running migration: migrate_hidden_ids
2023-03-18 20:42:30,882: Running migration: migrate_steam_appids
2023-03-18 20:42:30,884: Running migration: migrate_banners
2023-03-18 20:42:30,902: Running migration: retrieve_discord_appids
2023-03-18 20:42:30,903: Updating Games Discord APP ID's
2023-03-18 20:42:31,244: Downloading DXVK-NVAPI v0.6.2...
2023-03-18 20:42:31,245: Downloading to /home/sasha/.local/share/lutris/runtime/dxvk-nvapi/dxvk-nvapi-v0.6.2.tar.xz
2023-03-18 20:42:33,900: Extracting /home/sasha/.local/share/lutris/runtime/dxvk-nvapi/dxvk-nvapi-v0.6.2.tar.xz to /home/sasha/.local/share/lutris/runtime/dxvk-nvapi/v0.6.2
2023-03-18 20:42:33,900: Extraction failed: not an lzma file
2023-03-18 20:42:33,900: Error while completing task <bound method LutrisInitDialog.run_init of <dialogs.LutrisInitDialog object at 0x7fbaf64f4c80 (lutris+gui+dialogs+LutrisInitDialog at 0x56293bf890f0)>>: <class 'lutris.util.extract.ExtractFailure'> not an lzma file
  File "/usr/lib/python3.10/site-packages/lutris/util/", line 34, in target
    result = self.function(*args, **kwargs)
  File "/usr/lib/python3.10/site-packages/lutris/gui/dialogs/", line 284, in run_init
  File "/usr/lib/python3.10/site-packages/lutris/", line 228, in update_runtimes
  File "/usr/lib/python3.10/site-packages/lutris/", line 218, in <lambda>
    self.add_update(key, lambda c=dll_manager_class: self._update_dll_manager(c), hours=6)
  File "/usr/lib/python3.10/site-packages/lutris/", line 224, in _update_dll_manager
  File "/usr/lib/python3.10/site-packages/lutris/util/wine/", line 268, in upgrade
  File "/usr/lib/python3.10/site-packages/lutris/util/wine/", line 132, in download
    extract_archive(archive_path, self.path, merge_single=True)
  File "/usr/lib/python3.10/site-packages/lutris/util/", line 139, in extract_archive
    raise ExtractFailure(str(ex)) from ex

Here. It’s for a fresh install of lutris-git(stable doesnt work with same error), after removing all files and dependencies from the last install.

Games are League of Legends and GTA V. They were running perfectly, but all of a sudden when I restarted lutris it started to show “not an lzma file” every time I try to turn it on and for both games.

I’m getting same error even with flatpak version.

I’m also having this problem, it seems it happens from the games emulated with wine, it was after the update of manjaro-firmware or the kernel61.

Well, I have kernel61, but it worked for quite some time with it. Don’t know about manjaro-firmware update, but I know It didn’t happen withing the time when it worked and then stopped to do so, since I didn’t launch any updates(and I don’t use automatic ones).

Can’t reproduce:

2023-03-18 13:11:45,491: Downloading DXVK-NVAPI v0.6.2...
2023-03-18 13:11:45,492: Downloading to /home/yochanan/.local/share/lutris/runtime/dxvk-nvapi/dxvk-nvapi-v0.6.2.tar.xz
2023-03-18 13:11:45,950: Extracting /home/yochanan/.local/share/lutris/runtime/dxvk-nvapi/dxvk-nvapi-v0.6.2.tar.xz to /home/yochanan/.local/share/lutris/runtime/dxvk-nvapi/v0.6.2

What update? That package has not been updated in years and is no longer in the repos. Remove it if you still have it installed.

This is not kernel related. It’s either an issue with Lutris itself or a local issue with xz which handles the extraction of the files in question.

I have the same problem with Lutris

  Host: ujin-desktop Kernel: 6.1.19-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.26.5 Distro: Manjaro Linux
  Type: Desktop System: Gigabyte product: A320M-S2H v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: A320M-S2H-CF v: x.x serial: <superuser required>
    UEFI: American Megatrends v: F53 date: 01/05/2021
  Info: quad core model: AMD Ryzen 3 2200G with Radeon Vega Graphics bits: 64
    type: MCP cache: L2: 2 MiB
  Speed (MHz): avg: 1530 min/max: 1600/3500 cores: 1: 1426 2: 1600 3: 1565
    4: 1532
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    driver: amdgpu v: kernel
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8 driver: X:
    loaded: amdgpu unloaded: modesetting dri: radeonsi gpu: amdgpu
    resolution: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.3.5 renderer: AMD Radeon RX 480 Graphics
    (polaris10 LLVM 15.0.7 DRM 3.49 6.1.19-1-MANJARO)
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    driver: snd_hda_intel
  Device-2: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Sound API: ALSA v: k6.1.19-1-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8168
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: b4:2e:99:1c:50:78
  Local Storage: total: 931.51 GiB used: 62.75 GiB (6.7%)
  ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08WN4A0
    size: 931.51 GiB
  ID-1: / size: 915.53 GiB used: 62.75 GiB (6.9%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat
    dev: /dev/sda1
  Alert: No swap data was found.
  System Temperatures: cpu: 33.8 C mobo: N/A gpu: amdgpu temp: 47.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 868
  Processes: 232 Uptime: 1h 47m Memory: 7.71 GiB used: 2.54 GiB (32.9%)
  Shell: Zsh inxi: 3.3.25

While posting system information is usually very helpful, in this case it is not. This is a specific issue with an application. We need…


It fixed itself and now works. Though with a few changes.
You can see on the image that panel with “play” button is oversize. Also for sources only Lutris has icon, everything else had red square/something like that(like image not found placeholder), so I hide it.

Otherwise seems to be fine now. I didn’t even restart the system, but I did in fact used Heroic Launcher with one of the games. Maybe it used some of the stuff that shared between it and Lutris and repaired it, Idk.

I’ll leave this post open since there are other people with the problem and still no definitive solution.

What does that mean? How will that help others reading this post?

What does that have to do with the original issue? Either way, it’s probably an issue with your Gtk theme.

Seems to be an issue in Lutris:

For those who have still issues, there are some suggestions in the GitHub page to try.

Nope. The Glorious Eggroll broke it, but now it’s fixed. :wink:

fixed already. it was due to me uploading dxvk and dxvk-nvapi releases in the wrong format. ive corrected the release files now.

Error on Lutris and game launch - Not a lzma file · Issue #4776 · lutris/lutris · GitHub

[2023-03-16T21:18:20-0300] [ALPM] running '60-mkinitcpio-remove.hook'...
[2023-03-16T21:18:20-0300] [ALPM] running 'thunderbird-pre.hook'...
[2023-03-16T21:18:20-0300] [ALPM] transaction started
[2023-03-16T21:18:20-0300] [ALPM] upgraded linux-firmware-whence (20230117.7e4f0ed-1 -> 20230210.bf4115c-1)
[2023-03-16T21:18:21-0300] [ALPM] upgraded linux-firmware (20230117.7e4f0ed-1 -> 20230210.bf4115c-1)
[2023-03-16T21:18:23-0300] [ALPM] upgraded linux61 (6.1.12-1 -> 6.1.19-1)
[2023-03-16T21:18:23-0300] [ALPM] upgraded linux61-virtualbox-host-modules (7.0.6-9 -> 7.0.6-17)
[2023-03-16T21:18:24-0300] [ALPM-SCRIPTLET] In order to use the new version, reload all virtualbox modules manually.
[2023-03-16T21:18:24-0300] [ALPM] upgraded manjaro-release (22.0.4-1 -> 22.0.5-1)
[2023-03-16T21:18:26-0300] [ALPM] upgraded onlyoffice-desktopeditors (7.3.0-1 -> 7.3.3-1)
[2023-03-16T21:18:26-0300] [ALPM] upgraded thunderbird (102.8.0-1 -> 102.9.0-0.1)
[2023-03-16T21:18:26-0300] [ALPM] transaction completed
[2023-03-16T21:18:27-0300] [ALPM] running '30-systemd-tmpfiles.hook'...
[2023-03-16T21:18:27-0300] [ALPM] running '30-systemd-update.hook'...
[2023-03-16T21:18:27-0300] [ALPM] running '60-depmod.hook'...
[2023-03-16T21:18:28-0300] [ALPM] running '90-mkinitcpio-install.hook'...
[2023-03-16T21:18:28-0300] [ALPM-SCRIPT

this a update for day 16-03-2023, more for but curiously I had already restarted the machine twice, I restarted it once and lustris returned to normal, maybe it was just a bug. I thought directly about the update because it happened right after installing and restarting, but I think it was pure coincidence with the lutris bug and its library to work with wine nothing else. My apologies if I cause confusion.

This thread is solved. If you need further assistance, please create your own Support topic and reference this one if applicable.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.