Lutris not opening

Running Manjaro KDE Kernel 6.2.0-1.
I am trying to install lutris from the official repo, however, it just doesn’t open. When I try to launch it, I see the lutris icon with loading for a sec on the taskbar and then it just goes away. The version from flatpak just works fine btw. I have also tried AUR and that doesn’t open too.
What seems to be the problem here?

Run it in the terminal by entering lutris. Post the output here as code.

Usually there is no problem.

Traceback (most recent call last):
  File "/usr/bin/lutris", line 52, in <module>
    from lutris.gui.application import Application  # pylint: disable=no-name-in-module
ModuleNotFoundError: No module named 'lutris'

this is what i get in terminal

What about reinstalling? It looks pretty much that you broke lutris by installing the aur version.

pamac reinstall lutris

still getting the same error

Please run:

sudo pacman -Qkk lutris

and post the output here.

Where is it looking? Please post the output of the following:

which python
python -m site

Please see:

    ~  which python                                                                                                  ✔ 
    ~  python -m site                                                                                                ✔ 
sys.path = [
USER_BASE: '/home/noname/.local' (exists)
USER_SITE: '/home/noname/.local/lib/python3.10/site-packages' (doesn't exist)
    ~                                                                                                                ✔

Okay I solved it, I had previously installed python 3.11.2 directly from the source and that was messing up the whole thing. Uninstalled that and lutris works now! Thank You guys

1 Like

Please don’t forget to mark your post as a solution