Lutris/Manjaro : amdgpu_device_initialize: DRM version is 2.50.0 but this driver is only compatible with 3.x.x

Hi !

I tried a LOT of things. I will do it again if someone ask me too, but just so you now that I did search a lot, but I can’t understand what’s going on here.

As I said, I tried different solutions but each time it didn’t do a thing or it broke my Manjaro (not totally though, didn’t have to make a clean install)

So yeah, I can’t launch almost any game (tried 5) and I think it comes from the error in the title, or it is linked at least (It’s all linked to my drivers I think)

The issue comes from launching lutris with a term (Lutris is launching anyway, but I can’t seem to make something work, and I would like to remove all issues that could prevent others things to work (games especially))

If you have any idea, suggestion or whatever, I’ll take it !

your video card cant support this game ,
version driver is 2.5 max , game required 3.0

That’s it ? It’s that simple ?

Why Lutris is launching ? And how do I know which game I can’t play ? And why do I can play them on Windows ?

Lutris is usually using dxvk for windows games which needs a vulkan supported gpu.

Could you return the output of:

sudo inxi -Gxxxa

from the terminal.

And maybe install vulkan-tools and check with vulkaninfo if your gpu supports vulkan.

Maybe you have also the radeon and the amdgpu driver both activated. According to some posts they don’t play nice together at the same time:

lspci -nnk | grep -i vga -A3 | grep 'in use'



1 Like

sudo inxi -Gxxxa :

Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Tahiti PRO [Radeon HD 7950/8950 OEM / R9 280] vendor: Gigabyte
           driver: radeon v: kernel alternate: amdgpu bus ID: 01:00.0 chip ID: 1002:679a 
           Display: server: X.Org 1.20.8 driver: ati,radeon unloaded: modesetting alternate: fbdev,vesa display ID: :0.0 
           screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27") 
           OpenGL: renderer: AMD TAHITI (DRM 2.50.0 5.8.0-2-MANJARO LLVM 10.0.1) v: 4.5 Mesa 20.1.5 direct render: Yes


ERROR: [Loader Message] Code 0 : /usr/lib32/ wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : /usr/lib32/ wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : /usr/lib32/ wrong ELF class: ELFCLASS32
amdgpu_device_initialize: DRM version is 2.50.0 but this driver is only compatible with 3.x.x.
WARNING: [Loader Message] Code 0 : terminator_CreateInstance: Failed to CreateInstance in ICD 2.  Skipping ICD.
ERROR at /build/vulkan-tools/src/Vulkan-Tools-1.2.146/vulkaninfo/vulkaninfo.h:240:vkEnumerateInstanceExtensionProperties failed with ERROR_INITIALIZATION_FAILED

lspci -nnk | grep -i vga -A3 | grep 'in use'

Kernel driver in use: radeon

Edit : My graphics card should run Vulkan but I saw somewhere that it’s somewhat experimental (My graphics card is GCN 1)

1 Like

To be honest i have never run a amd gpu with vulkan, but as on nvidia there are vulkan libs needed.

vulkan-radeon and lib32-vulkan-radeon?

I believe amdvlk and lib32-amdvlk are only compatible with the newest amd driver which supports only the newest gpus.


I got both vulkan-radeon and lib32-vulkan-radeon

I got both amdvlk and lib32-amdvlk also. I should uninstall them ?

I looked it up:

Product Support
The AMD Open Source Driver for Vulkan is designed to support the following AMD GPUs:
Radeon™ HD 7000 Series
Radeon™ HD 8000M Series
Radeon™ R5/R7/R9 200/300 Series
Radeon™ RX 400/500 Series
Radeon™ M200/M300/M400 Series
Radeon™ RX Vega Series
Radeon™ RX 5700/5500 Series
AMD FirePro™ Workstation Wx000/Wx100/Wx300 Series
Radeon™ Pro WX x100 Series
Radeon™ Pro 400/500 Series
Radeon™ W5700/W5500 Series

Seems your gpu support amdvlk :slight_smile:

Could you send the output of:

mhwd -li -d

Maybe you have to blacklist the radeon driver so that the amdgpu driver will be used.

Nice. I saw some sources telling me the same thing, but there’s contradictions everywhere so I wasn’t quite sure.

   NAME:	network-r8168
   VERSION:	2016.04.20
   INFO:	RealTek RTL-8168 Gigabit Ethernet driver
   CLASSIDS:	0200 
   VENDORIDS:	1186 10ec 

   NAME:	video-linux
   VERSION:	2018.05.04
   INFO:	Standard open source drivers.
   CLASSIDS:	0300 0380 0302 
   VENDORIDS:	1002 8086 10de 

Warning: no installed configs for USB devices found!

It seems as I expected that I’m not using the radeon driver even if its installed.

Here :arrow_up: You are using the radeon driver.

Ive found a solution in the old forum: Solved! Can't find a way to switch from radeon to amdgpu - Technical Issues and Assistance - Manjaro Linux Forum

You need to add amdgpu to the MODULES in /etc/mkinitcpio.conf.

sudo nano /etc/mkinitcpio.conf

replace MODULES="" with MODULES="amdgpu"
then sudo mkinitcpio -P


then check with

If the driver amdgpu is in use.

Then install amdvlk and lib32-amdvlk.



We should probably get video-linux to tag this GPU for amdgpu instead of radeon. Didn’t even know radeon even still existed.

1 Like

But why


I already have that :


And amdvlk and lib32-amdvlk are already installed in my system.

I’m not sure what you mean.

video-linux is installing the correct driver and installed radeon instead of amdgpu ?

weird… ok… then it backfalls to radeon? sorry idk why, but a possible solution would be blacklisting the radeon module.

sudo echo "blacklist radeon" > /etc/modprobe.d/blacklist-radeon.conf

check if it was successful:
cat /etc/modprobe.d/blacklist-radeon.conf

reboot and only amdgpu driver should be loaded.

1 Like

Yeah it’s weird. It seems to work for a lot of people but not for me. Maybe I missed something ?

I already did blacklist the radeon module, but all I got was a black screen (or Light Display Manager couldn’t launch, something like that). If I want to retrieve my desktop I must use one of the TTY and reverse the changes (AKA whitelist radeon module)

Did you try also this?

How should I flag the post ?

Oh yeah ! If I put what I should, I got a Light Display Manager error, and if I put the other one, nothing specific happens.

no need… i flagged is as deleted. It will remain 24h until is deleted forever.

How should I flag the post ?

1 Like

When amdgpu activated and lightdm failed. Switch to another tty by pressing CTRL+ALT+F3.

Then type this: sudo lightdm –-test-mode --debug

Could you post the output of it?