LUKS password prompt doesn't show up

I’ve installed Manjaro with the open source drivers for my Nvidia RTX 3050 and encrypted my hard disk with Luks. So far, everything worked fine. When booting, the system showed the password screen, I entered my password and Manjaro started just fine.

However, after installing the proprietary Nvidia driver by using the KDE Plasma hardware installation tool the password screen doesn’t show at all but I’m still able to enter the password and Manjaro will start. Still, the first screen I’ll see is the SDDM login screen.

I already reinstalled Manjaro once but this issue occurs after every installation of the proprietary Nvidia drivers. Using the open source version is unfortunatly not a valid option for me so I ask you kindly to help me solving this problem.

Kind regards,

Most likely, if you only have a nvidia card, you need to include the nvidia modules to initcpio:

File: /etc/mkinitcpio.conf

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

Run: sudo mkinitcpio -P

Also set GRUB_GFXMODE=auto to GRUB_GFXMODE=1920x1080 or what ever you need and run sudo update-grub

1 Like

Hello and thank you for your quick response. I’ve tried it before already but tried it again exactly how you told, but it didn’t work. Any other ideas?

Plymouth needs modesetting what is an experimental feature in nvidia and can be enabled “opt-in”, but normal for open source modules. Sorry,I didn’t consider this since I don’t use nvidia.

Take a look here:

So adding the modules is done already. Now you need to enable modesetting and tell that nvidia should use its own framebuffer:

nvidia_drm.modeset=1 nvidia_drm.fbdev=1

Hi there,

doesn’t work. :neutral_face:

UPDATE: System needed to be shut down completely. Thanks for helping! :kissing_heart:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.