Low screen resolution while 'Enter passphrase for hdx,gptx' before accessing GRUB

Hello Happy Manjaro Users (my fav Linux Distro since many years now - not a single break of my system!!)!!

may ask for your help and advice!?

much appreciated community, even this my 1st post now, have to say ‘Thanks’ for knowledge I could collect within Manjaro Community in the past!!

okay, so my very little (but annoying) problem nowadays is the low screen resolution (before enter into GRUB) when getting asked to enter password for LUKS device.

GRUB itself comes with my preferred resolution!

strange thing if I enter the same scenario after doing F11 UEFI boot menu option (choosing same OS), I would always get my preferred, higher resolution at the LUKS password dialog.!!

much appreciate any help because find it annoying since I was used for years to get high resolution from starting on. tried myself quite a lot for hours but unluckily cldnt solve by myself.

Mainboard ASRock B450M Pro4 (Vers. 5.30)
might be UEFI update a few weeks ago the reason?

ok, thx, so long post
have a nice day folks and hope to hear from you


Hello @alpha :wink:

Probably just set the correct resolution? Example:

File: /etc/default/grub


Don’t forget update-grub :wink:

You musn’t be doing things right.

1 Like

Got correct settings inside grub,
UEFI also set to ‘auto’ video (1920x1080),
IMHO question for LUKS passphrase arrives before GRUB is starting
thx anyway for trying to help,

That is a wrong assumption. The password prompt of luks is part of grub. When it start it inherits the screen resolution of the UEFI/BIOS. The whole decryption part must be embedded into the efi file in case of full encryption.

I guess there is nothing you can do, other than I suggested, since hard coded.

1 Like

Interestingly, if you were using rEFInd UEFI bootloader as well as GRUB 2, 1920x1080 would be inherited from rEFInd (which loads before GRUB 2).

sudo pacman -S refind
sudo refind-install

Just some random info to add to the mix. Cheers.

1 Like

rEFInd didnt do the trick,
might have to access grubx64.efi,
any ideas how to configure?

You would of course need to configure rEFInd to render at 1920x1080. I’m afraid I don’t have access to that configuration information at the moment. Cheers.

My take on this is it’s by design, i.e. a failsafe. It’s all nice and dandy forcing a resolution during early startup stages, but what happens if your monitor/graphics card go kaput and you need to use another display which doesn’t support the newer resolutions? Then it’s up the creek without a paddle.

Same issue with certain game consoles … set to a high resolution from bootup, then try to get it working with a legacy display without going down the rabbit hole!

am sorry soundofthunder, rEFInd didnt help at all and got deleted,
no need for intermediates inside boot process…
relevant output of my /boot/grub/grub.cfg looks like this:
function load_video {
if [ x$feature_all_video_module = xy ]; then
insmod all_video
insmod efi_gop
insmod efi_uga
insmod ieee1275_fb
insmod vbe
insmod vga
insmod video_bochs
insmod video_cirrus

Nothing ventured, nothing gained. I have nothing more to add, sorry.

Good luck.

no worries mate,
and thx for contribute

I really do not understand the question - perhaps a language thing.

First is the passphrase request graphical or textual?

How I understand low resolution is 640x480 - that is is the original VGA.

If you are using Plymouth you get a nice graphical prompt but your topic title seems to indicate the prompt is textual.

If the passphrase is textual - the higher the resolution the smaller the text - meaning on a laptop with a 2880x1800 resolution the passphrase request becomes quite difficult to see. Not that it matters - simply input the phrase and hit enter.

You may be able to counter act this by setting the preferred font and size in /etc/vconsole.conf and rebuild you init.

Linux console - ArchWiki

Users booting though UEFI may experience the console and boot loader being constrained to a low resolution despite correct KMS settings being set. This can be caused by legacy/BIOS boot being enabled in UEFI settings. Disabling legacy boot to bypass the compatibility layer should allow the system to boot at the correct resolution.
HiDPI - ArchWiki

Your /etc/mkinitcpio should contain a hook for consolefont - something like this

HOOKS=(systemd microcode plymouth modconf keyboard keymap consolefont block filesystems fsck)


1 Like

Thx arhus,
no legacy was enabled, hooks in mkinitcpio are fine, vconsole.conf edited and restarted service.
passwd prompt still arrives at 640x480
From what I read, see below text from Archwiki might be the reason:

If the fonts appear to not change on boot, or change only temporarily, it is most likely that they got reset when graphics driver was initialized and console was switched to framebuffer. By default, all in-tree kernel drivers are loaded early, NVIDIA users should see NVIDIA#Early loading to load their graphics driver before /etc/vconsole.conf is applied.

Nvidia are typically famous for ignoring the boot experience. I recall most graphics devices (for years) came with a complimentary thick black border around the screen during boot that was impossible to lose. Of course, if your boot screen was already black, that was less of an eyesore.

I guess this was another effort to mitigate calibration (image positioning) issues on the monitors we had at the time. At least with later ones we could calibrate per-resolution, then later with “auto-adjust” (which is still not perfect).