Low RTTIME limit detected

Hello everyone, i hope you are doing well.
After applying the latest manjaro-gnome full update from few days ago, i experience a message “Low RTTIME limit detected” after starting any Musicmaking application (Reaper or Ardour, e.g.) and when a Windows-VST Plugin is loading via yabridge and wine-staging. All was working well for almost years before, ans i checked twice all the usual realtime-settings (manual and via scripts). Also i tried different rollbacks of wine-staging versions. No success.

I reinstalled my 2 months old full system image, and everything is working out of the box. After applying the update (i even tried to not update the rt-kernel for testing) the message comes immediately by loading a windws-vst. I checked the usual how-tos and any hint in the internet… but for now i am really out of ideas… so if you got any hints or experience the same problem, maybe we find a solution together. Thanks a lot in advance!.
Cannot attach a Screenshot so heres is the attending message:
LOW RTTIME limit detected

RLIMIT_RTTIME is set to 200000us. This can happen when using PipeWires Jack Backend with RTKit instead of regular realtime scheduling.

I am not using Pipewire, i am using Jack2 with Cadence as GUI… seems Manjaro has changed some things here…

Welcome to Manjaro forum @hauiproductions

If you are using jack2 and cadence, system should be configured for realtime scheduling

I suggest check realtime priority rtprio and maximum locked memory memlock configuration

ulimit -R -t


grep -H -e rtprio -e memlock /etc/security/limits.d/

Arch-based distributions can use either the audio group or realtime group for these configurations

/etc/security/limits.d/99-realtime-privileges.conf:@realtime - rtprio 98
/etc/security/limits.d/99-realtime-privileges.conf:@realtime - memlock unlimited

To run a full check of realtime configuration install and run rtcqs from AUR

pamac build rtcqs; rtcqs

rtcqs is not aware of realtime group and checks audio group only

Hi nikgnomic, thanks for your fast answer.

All looks good, in rtcqs all green/ok and in
is rtprio 98 and memlock unlimited…

ulimit -r -t also says 98 and unlimited…

All happens after the recent manjaro update, i tested it again right now… strange!
Any other suggestions? Thanks a lot…

Check PulseAudio configuration

pulseaudio --dump-conf | grep rttime

If response is:

rlimit-rttime = 200000

run this command

tee -a ~/.config/pulse/daemon.conf <<< 'rlimit-rttime = -1'

and restart PulseAudio

systemctl --user restart pulseaudio

Thanks for your answer, the response was
rlimit-rttime = -1

Still the message appears when starting a windows vst via yabridge … i wonder in which config file is rlimit-rttime = 200000… and how to find it… is it a good idea to scan all files on my pc searching for this entry?

If the message appears when starting a VST via yabridge the error is most likely either from yabridge or WINE

I suggest:

  1. Try using VST plugins with a different plugin host (e.g. carla or fst) or use Linux LV2 plugins

  2. Read yabridge documentation for how to get debugging data and report a bug

  3. Ask for help with yadbridge and VSTs on linuxmusicians.com forum

Hi and thanks again for helping,

some news, the error also comes up with Carla Plugin Host, so yabridge is not the troublemaker…
i will now get back to some very old wine-staging versions tot test if it comes up again…

EDIT: So even downgrading to wine-staging 7.20 does not change a thing…

I wish i knew where to set rlimit-rttime from 200000 to -1

This setting seems to be somewhere, and is read by the configuration…

Starting the Windows VST Synth directly with wine makes no problem, just when the vst is started in the DAW (via .dll) the message appears.

And another update,
today i saw that the RTTIME message appears before even the dialogue “wine is updating” (i updated my downgraded version 7.2 to actual version) for loading the VSTi is gone.

Update: I added myself now to root/sudo group (just for testing) and also installed for testing the liquorix-rt kernel… no change :frowning:

But with the liquorix-kernel, the WinVST plugins are loading and playing well… The RTTIME Message still comes up after loading every Win VSTi …

But it seems that they are working (still testing…)

With Manjaro-RT Kernel the VST plugins fail completely to load.

Liquorix kernel and VST plugins are both third party applications as far as Manjaro is concerned
but Linuxmusicians forum should be able to help with both
(Liquorix is the default kernel in AVLinux and AVLinux developer GMaq posts on linuxmusicians forum regularly)

You should try using Manjaro standard (lowlatency) kernel instead of RT kernel and that may not have problems with VST
Philm has included most of the pro-audio realtime patches in Manjaro standard kernels
The only additional configuration needed for a standard Manjaro kernel is to install package rtirq and add “threadirqs” boot option to /etc/default/grub/

I have used standard Manjaro kernel for the last 3-4 years and not had any problems running JACK
(But I gave up on VST plugins when I left winXP because most didn’t work on Linux back then, and I had content to produce so I used native LADSPA plugins instead)

So my - hopefully temporary - solution is:

Using the liquorix-rt-kernel when making music.

This kernel is right now the only option for me that my VST Instruments are loading. The error message still appears, but i can live with that.

All projects that i loaded were playing as before.

When i boot on exact the same machine with manjaro-rt kernel - the plugins fail.

I will keep an eye on it, and yes i will of course try to get someday rid of the Win-VST Plugins :slight_smile:

When future Manjaro updates will not fix this error message / issue maybe it is time to make a new install from scratch… with Manjaro or another distro like AVLinux …
So thanks everyone for helping, i will keep you updated in the future on this topic !

Some VST plugins could be replaced with CLAP plugins - Hosts and Plug-Ins - CLever Audio Plug-In
but Ardour developers are not considering support for another audio plugin standard yet

Can you suggest any simple and free VST plugins that can be used for testing kernels?
I don’t think it very likely that Manjaro team will know what to fix in kernel unless they have first-hand experience of VST errors

Update: I did
find / -type f -name jack.conf
find / -type f -name pipewire.conf
as su, just to see if there are some config files somewhere…

I found some config files, where the limit was set to 200000 instead of -1… most in ./flatpak./
but unfortunately after changing it to the correct value and reboot… the error message is still there…

…and it also comes up without starting jack with cadence before… i accidentally started reaper without starting jack before… and also the error comes up (of course with other errors)

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.