Low memory blocking limit detected

Hello, everyone:

I receive the following system notification whenever I launch the DAW ‘Reaper’ and insert a VST in a track:

 - Low memory locking limit detected: The current memlock limit is set to 1048576 bytes. This means that you have not yet set up realtime privileges for your user (which I have), and some plugins may cause your DAW to crash until you fix this. Check the readme for instructions on how to do that.

These are my /etc/security/limits.conf contents:

#* soft core 0
#* hard rss 10000
#@student hard nproc 20
#@faculty soft nproc 20
#@faculty hard nproc 50
#ftp hard nproc 0
#@student - maxlogins 4

audio group

@audio - rtprio 95
@audio - memlock unlimited
@audio - nice -10
@realtime hard rtprio 20
@realtime soft rtprio 10

End of file

I know it’s kind of a mess, but this is due to the confusion reading on several forums and websites has brought me. I have tried many things, amongst which, there have been several memory limits changes.
I have also read that my user must belong to the audio group. And it does:

[alberto@alberto-macpro51 security]$ groups
network power users storage lp input audio wheel alberto

There is one more thing that comes into my mind: If I’m not mistaken, there is a ‘realtime’ group as well. May the problem be that I do not belong to that group?

By the way: I’m running Manjaro Gnome=(41.3) (64 bit) on a Intel Xeon CPU with 8 cores at 2.80Ghz, 32GB of RAM. I’m using a M-Audio Fast Track MKII audio interface.

Thank you very much in advance.


Have you installed realtime-privilages package?
I think it not “MUST” but maybe you can address the problem.


It worked flawlessly!! Thank you very much for your help. I really appreciate it. :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.