Lost sound on Omen laptop

Hello. I seem to have lost all sound output devices recently. Sound Output device only has one option: Dummy Output. The internal speakers nor the headphone jack has sound. I also tried to hook it up to a bluetooth speaker but it won’t connect. All these were working a few days ago.

inxi -Fazy yields:
inxi -Fazy  :heavy_check_mark:
Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64
root=UUID=cda9dde6-bc77-4054-afd8-24b49cb2384a rw quiet splash apparmor=1
security=apparmor udev.log_priority=3 acpi_backlight=vendor
Desktop: GNOME 40.5 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1
Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: HP product: OMEN by HP Laptop 15-dh1xxx v: N/A
serial: Chassis: type: 10 serial:
Mobo: HP model: 8746 v: 04.33 serial: UEFI: AMI v: F.20
date: 11/04/2020
ID-1: BAT1 charge: 57.4 Wh (100.0%) condition: 57.4/69.0 Wh (83.2%)
volts: 12.7 min: 11.6 model: COMPAL PABAS0241231 type: Li-ion
serial: status: Full
Info: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP
arch: Comet Lake family: 6 model-id: A5 (165) stepping: 2 microcode: EA
cache: L2: 12 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 62431
Speed: 800 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 800 2: 3452
3: 3319 4: 2322 5: 1278 6: 804 7: 800 8: 800 9: 840 10: 841 11: 900 12: 849
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA TU104BM [GeForce RTX 2070 SUPER Mobile / Max-Q]
vendor: Hewlett-Packard driver: nvidia v: 470.63.01
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1ed1
class-ID: 0300
Device-2: Lite-On HP Wide Vision HD Camera type: USB driver: uvcvideo
bus-ID: 1-5:3 chip-ID: 04ca:707f class-ID: 0e02 serial:
Display: x11 server: X.org 1.20.13 compositor: gnome-shell driver:
loaded: nvidia resolution: <missing: xdpyinfo>
OpenGL: renderer: NVIDIA GeForce RTX 2070 Super with Max-Q Design/PCIe/SSE2
v: 4.6.0 NVIDIA 470.63.01 direct render: Yes
Device-1: Intel Comet Lake PCH cAVS vendor: Hewlett-Packard
driver: sof-audio-pci-intel-cnl
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:06c8 class-ID: 0401
Device-2: NVIDIA TU104 HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f8
class-ID: 0403
Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.38 running: yes
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus-ID: 3d:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp61s0 state: down mac:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:4 chip-ID: 8087:0026 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Not an ARRAY reference at /usr/bin/inxi line 16007.

Troubleshooting steps I took:
I have tried to change kernels but without a resolution. On stock now. Please note that if I hook up an HDMI cable to a monitor, that shows up as an output device. However, the monitor doesn’t have speakers. I have 2 users set up and both are affected.
Also, based on another thread I installed sof-firmware but there wasn’t a change.

Well, I seemed to have stumbled upon an answer, a command, whereby it would reinstall everything:

pacman -Qqn | pacman -S -

The sound seems to be back now and the devices (headphones and speakers) are back in the sound panel. Bluetooth speaker had to be re-paired.

Kernel v5.13 is no longer supported on Manjaro
Kernel v5.14 has been marked End Of Life in update announcements and not be supported by Manjaro soon

I suggest you install kernel v5.15 using Manjaro Settings Manager GUI
( manjaro-settings-manager -m msm_kernel )

OR use these terminal commands to install new kernel and remove old one

sudo mhwd-kernel --install linux515
sudo mhwd-kernel --remove linux513

Later kernel may have better support for audio device Intel Comet Lake PCH cAVS (Realtek ALC295)