Lost "Configure Desktop" Desktop right click menu

Hi All
I accidentally changed the right click menu for the desktop to an application menu and now i cant find a way to change it back or even open the “Desktop Settings”
Any help would be appreciated!

from where did you change you will find it there

I changed it in kde desktop by right clicking on desktop and hitting “Configure desktop” but obviously changing the right click setting to “Application menu” made it difficult to change back as i cant get to that application any more and i have searched to find a manual way to open it with no success, there is a shortcut key witch is supposed to be alt + d or alt + s to open it but this does not work on manjaro kde plasma.

I see you used the shortcut keys. They are documented in the KDE Doc. Look for “Working with the Desktop”, Common Keyboard Shortcuts. They worked on my Manjaro KDE system, both left and right alt. I held down the “alt key” and then pressed “d” and then pressed “s”, and then released the “alt key”. Make sure you are positioned on the desktop.

Ah, I see in the doc:

Well, that’s confusing.

Maybe it worked on my system because I made sure my cursor was on the desktop, not touching anything.

Another option is to just edit the file $HOME/.config/plasma-org.kde.plasma.desktop-appletsrc. At the very top are the Mouse Actions.
Change Rightbutton to RightButton;NoModifier=org.kde.contextmenu.
Might need to logon/off with this option.

I do the same thing, make sure cursor is on the desktop but still my alt+d does not work the alt+s does but brings up the workspace switcher. Changing the values on the appletsrc worked perfect!
Thank You!

Yeah. I think ours is working the same. Here’s the strangeness.

alt-d + alt-s never worked for me with Layout = Folder View, alt-d+s is a different story.

When I first logon and type alt-d+s, I get the Activity Switcher. But if I right-click the desktop and select “Configure Desktop and Wallpaper”, close it, and now type alt-d+s, I get “Configure Desktop and Wallpaper”, every single time. I found out, if I just right-click the desktop, that is even to get the shortcut key to work correctly.

It’s got to be more than us :slightly_frowning_face: :slight_smile:

Glad you got a solution.

Another way to get to Configure Desktop

In KDE 4, there was an widget in the corner, called the cashew, which I think they started calling the toolbox. And then it was replaced with the Global Edit bar.

To get the Global edit bar, they say you can right-click the desktop and select “Customize layout”. At some point, this must have been changed to “Enter Edit Mode” which has a shortcut of, Alt+D,E — that’s alt-d, release alt and type e. If the shortcut works (and this one did for me), this is another way to get to “Configure Desktop and Wallpaper”.

If widget’s are locked, Alt+D,L (toggle), “Enter Edit Mode” will be disabled/grayed out.

Interesting, that did not work for me either, although, it did help me find another way to fix my problem and was way easier! Fix - Right click a panel hit “edit panel” the click the desktop and theres a bar at the top of the screen with various buttons and “Configure Desktop and wallpaper” YAY! haha now i feel dumb :laughing: