Lost all the mime relations on krusader after the latest big update

Hi there!
After the latest big update (almost 1000 packages here) I have lost all the mime type files relations in krusader…
I mean, when trying to open a file it ask, allways, which software should open it… even clicking on the remember button do not do anything… always ask for a software

Any idea what is happening? How to solve it?

Best regards and sorry for the bad english!


Just to clarify;
It is only krusader that has this issue?
MIME stuff is otherwise OK, and functions elsewhere?

Maybe also check, ex:

cat ~/.config/mimeapps.list

Well I saw this behavior in krusader (as I have it allways open, and using it)… but I have tried “caja”, the file manager of mate and it works ok in caja… when opening files, uses the app related to it as usual

I did a ```
cat ~/.config/mimeapps.list

And it seems to be ok

Ok, good to know.
I have virtually no experience with krusader though.
So good luck. :slight_smile:

sudo pacman -S kde-cli-tools
then restart Krusader.

1 Like

Ah, yes, should have looked at the optdepends

$ pacman -Si krusader
Repository      : extra
Name            : krusader
Version         : 2.8.1-1
Description     : Advanced twin panel (commander style) file manager
Architecture    : x86_64
URL             : https://krusader.org/
Licenses        : GPL-2.0-or-later
Groups          : None
Provides        : None
Depends On      : acl  gcc-libs  glibc  karchive5  kbookmarks5  kcodecs5  kcompletion5  kconfig5  kconfigwidgets5  kcoreaddons5  kguiaddons5  ki18n5  kiconthemes5  kio5  kitemviews5
                  kjobwidgets5  knotifications5  kparts5  kservice5  ktextwidgets5  kwallet5  kwidgetsaddons5  kwindowsystem5  kxmlgui5  qt5-base  solid5  zlib
Optional Deps   : 
                  kde-cli-tools: manage file associations, root mode

Oh, but kde-cli-tools was already installed (anyway, I have reinstalled it, nothing changes)

BTW, I was looking here bbs. archlinux.org/ viewtopic.php?id=295236 trying to find if it is related…

This worked reddit.com /r/kde/comments/1bd313p/comment/l1jinyf/
It seems name schemes have changed somewhere? I had to cp (not mv just in case something fails heheeh) the mate-applications.menu to applications.menu

Is this a manjaro issue too? In other replies I saw people recommending the instalation of archlinux-xdg-menu package, and running some commands later… that package did not exist in manjaro