Losing window focus after switching keyboard layout

So, basically it happens like this:
I am typing some message in Telegram or any other place, then i press “alt+c”, that is a shortcut in my system, that changes input source from one language to another and after pressing that i couldn’t type anything, because i king of stayed out from that window. More like switch to another, but it looks like i just stayed out every window
And to continue using Telegram i should click on it using my mouse or just press alt+esc or alt+tab
I tried finding some conflicting shortcut in dconf-editor, but all i find in gsettings get org.gnome.desktop.wm.keybindings was “switch input source”, that i already have in settings and switching it to any other shortcut doesn’t help at all.

You topic title and post are hard to follow. Please see the following and edit them accordingly to help us help you:

I just renamed the title to what i understood :wink:

I have no idea how switching keyboard layouts in Gnome is done, but if it helps:

  • In KDE the shortcut is Meta+ALT+K (Meta is the key with the Micro$@$ symbol)

I tried to explain it as much as i can and i do not see any place where i can improve it.
If it helps - i could record a video and paste here a link to it
Could i do it?

Everyone else does. Did you read the replies here?

Keep in mind this is a support forum with rules and tutorials, not Reddit where (almost) anything is acceptable.

Please do not post screenshots or videos. Most folks detest squinting at a screenshot and will not watch videos. Also, neither of the aforementioned can be copied and pasted nor indexed by a search engine.

Help us help you. :wink:

You’re experiencing a known mutter (Gnome display server/window manager) bug introduced in 43.3 that was fixed upstream just 3 days ago in mutter 44.rc:

I don’t know enough about the Gnome development cycle to know when you’d see this fix arrive, so hopefully someone else can chime in. For now, you can attempt to downgrade mutter if you don’t want to live with the bug until it’s fixed.


Thank you very much!) Coudn’t think of this, switching to GNOME instead of GNOME on Xorgs worked perfectly. Will switch back when they will fix this)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.