Losing connection every hour

Exactly 1 hour after connection has been established losing it for 30 sec to 1 min if i do nothing, if i disconnect/connect by myself it takes ~20 seconds.
There is nothing in journalctl while it’s happening, unless i reconnect myself.
Connection is wired, isp only provides cable straight to my apartment, so i can’t mess with router/modem


Kernel: 5.4.105-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64
root=UUID=0b1cd83f-7be5-49a8-90bf-f1e76a306ca6 rw quiet apparmor=1
security=apparmor udev.log_priority=3 systemd.unified_cgroup_hierarchy=true
Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7
dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux

Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel port: d000 bus-ID: 03:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac:

connection information:


connection.id: Wired connection 1
connection.uuid: 95fcce7f-0ed7-3424-87a0-65212a1a57ee
connection.stable-id: –
connection.type: 802-3-ethernet
connection.interface-name: enp3s0
connection.autoconnect: yes
connection.autoconnect-priority: -999
connection.autoconnect-retries: -1 (default)
connection.multi-connect: 0 (default)
connection.auth-retries: -1
connection.timestamp: 1617457148
connection.read-only: no
connection.permissions: –
connection.zone: –
connection.master: –
connection.slave-type: –
connection.autoconnect-slaves: -1 (default)
connection.secondaries: –
connection.gateway-ping-timeout: 0
connection.metered: no
connection.lldp: default
connection.mdns: -1 (default)
connection.llmnr: -1 (default)
connection.wait-device-timeout: -1

802-3-ethernet.port: –
802-3-ethernet.speed: 0
802-3-ethernet.duplex: –
802-3-ethernet.auto-negotiate: no
802-3-ethernet.mac-address: –
802-3-ethernet.cloned-mac-address: –
802-3-ethernet.mac-address-blacklist: –
802-3-ethernet.mtu: auto
802-3-ethernet.s390-subchannels: –
802-3-ethernet.s390-nettype: –
802-3-ethernet.s390-options: –
802-3-ethernet.wake-on-lan: default
802-3-ethernet.wake-on-lan-password: –

ipv4.method: auto
ipv4.dns-search: –
ipv4.dns-options: –
ipv4.dns-priority: 0
ipv4.addresses: –
ipv4.gateway: –
ipv4.routes: –
ipv4.route-metric: -1
ipv4.route-table: 0 (unspec)
ipv4.routing-rules: –
ipv4.ignore-auto-routes: no
ipv4.ignore-auto-dns: no
ipv4.dhcp-client-id: –
ipv4.dhcp-iaid: –
ipv4.dhcp-timeout: 0 (default)
ipv4.dhcp-send-hostname: yes
ipv4.dhcp-hostname: –

ipv4.dhcp-fqdn: –
ipv4.dhcp-hostname-flags: 0x0 (none)
ipv4.never-default: no
ipv4.may-fail: yes
ipv4.dad-timeout: -1 (default)
ipv4.dhcp-vendor-class-identifier: –
ipv4.dhcp-reject-servers: –

ipv6.method: disabled
ipv6.dns: –
ipv6.dns-search: –
ipv6.dns-options: –
ipv6.dns-priority: 0
ipv6.addresses: –
ipv6.gateway: –
ipv6.routes: –
ipv6.route-metric: -1
ipv6.route-table: 0 (unspec)
ipv6.routing-rules: –
ipv6.ignore-auto-routes: no
ipv6.ignore-auto-dns: no
ipv6.never-default: no
ipv6.may-fail: yes
ipv6.ip6-privacy: 0 (disabled)
ipv6.addr-gen-mode: stable-privacy
ipv6.ra-timeout: 0 (default)
ipv6.dhcp-duid: –
ipv6.dhcp-iaid: –
ipv6.dhcp-timeout: 0 (default)
ipv6.dhcp-send-hostname: yes
ipv6.dhcp-hostname: –
ipv6.dhcp-hostname-flags: 0x0 (none)
ipv6.token: –

proxy.method: none
proxy.browser-only: no
proxy.pac-url: –
proxy.pac-script: –

Activate connection details (95fcce7f-0ed7-3424-87a0-65212a1a57ee)

GENERAL.NAME: Wired connection 1
GENERAL.UUID: 95fcce7f-0ed7-3424-87a0-65212a1a57ee
GENERAL.STATE: activated
GENERAL.DBUS-PATH: /org/freedesktop/NetworkManager/ActiveConnection/3
GENERAL.CON-PATH: /org/freedesktop/NetworkManager/Settings/1

DHCP4.OPTION[2]: dhcp_lease_time = 7200
DHCP4.OPTION[10]: requested_broadcast_address = 1
DHCP4.OPTION[11]: requested_domain_name = 1
DHCP4.OPTION[12]: requested_domain_name_servers = 1
DHCP4.OPTION[13]: requested_domain_search = 1
DHCP4.OPTION[14]: requested_host_name = 1
DHCP4.OPTION[15]: requested_interface_mtu = 1
DHCP4.OPTION[16]: requested_ms_classless_static_routes = 1
DHCP4.OPTION[17]: requested_nis_domain = 1
DHCP4.OPTION[18]: requested_nis_servers = 1
DHCP4.OPTION[19]: requested_ntp_servers = 1
DHCP4.OPTION[20]: requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[21]: requested_root_path = 1
DHCP4.OPTION[22]: requested_routers = 1
DHCP4.OPTION[23]: requested_static_routes = 1
DHCP4.OPTION[24]: requested_subnet_mask = 1
DHCP4.OPTION[25]: requested_time_offset = 1
DHCP4.OPTION[26]: requested_wpad = 1

I think it would be worthwhile to ask about the router/modem setup if you can find out who managers the configuration. My mother moved to an apartment offering free WiFi, but the building was set up so all tenants had guest accounts that timed out after an hour. If you can, connect some other device that will use DHCP and see if it, too, has the connection drop after an hour. If it does, well, that points to the router/modem setup as the cause. Another possibility, if you have two devices and a hub, is to stagger the device connection times and see if they still drop each connection after exactly one our each. Good luck!

Isp technician will check it out and i ask him then, since i have static ip i changed automatic dhcp to manual and it still dropped after an hour, not sure if that goes around dhcp completely? Also i had that internet connection for years, this just started to happen last few days.

If it is not the router or ISP, then it could be the power management? But well, honestly I have never seen an issue there.

sudo tlp-stat --pcie

run it during internet loss


— TLP 1.3.1 --------------------------------------------

+++ PCIe Active State Power Management
/sys/module/pcie_aspm/parameters/policy = [default] performance powersave powersupersave

+++ Runtime Power Management
Device blacklist = (not configured)
Driver blacklist = amdgpu mei_me nouveau nvidia pcieport radeon

/sys/bus/pci/devices/0000:00:00.0/power/control = on (0x060000, Host bridge, hsw_uncore)
/sys/bus/pci/devices/0000:00:01.0/power/control = on (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:14.0/power/control = on (0x0c0330, USB controller, xhci_hcd)
/sys/bus/pci/devices/0000:00:16.0/power/control = on (0x078000, Communication controller, mei_me)
/sys/bus/pci/devices/0000:00:1a.0/power/control = on (0x0c0320, USB controller, ehci-pci)
/sys/bus/pci/devices/0000:00:1b.0/power/control = on (0x040300, Audio device, snd_hda_intel)
/sys/bus/pci/devices/0000:00:1c.0/power/control = on (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:1c.2/power/control = on (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:1d.0/power/control = on (0x0c0320, USB controller, ehci-pci)
/sys/bus/pci/devices/0000:00:1f.0/power/control = on (0x060100, ISA bridge, lpc_ich)
/sys/bus/pci/devices/0000:00:1f.2/power/control = on (0x010601, SATA controller, ahci)
/sys/bus/pci/devices/0000:00:1f.3/power/control = on (0x0c0500, SMBus, i801_smbus)
/sys/bus/pci/devices/0000:01:00.0/power/control = on (0x030000, VGA compatible controller, nvidia)
/sys/bus/pci/devices/0000:01:00.1/power/control = on (0x040300, Audio device, snd_hda_intel)
/sys/bus/pci/devices/0000:03:00.0/power/control = on (0x020000, Ethernet controller, r8169)


I would suggest to run this script:

curl --silent https://gitlab.com/-/snippets/2001562/raw/master/plwatch.sh | bash

It will send 5 pings to the local gateway (which is normally a router) and to google.com in paralell and record the summary of the 5 pings to a file called ping_log.txt.

This way you know at least, if it is a problem with the connection from the Router/ISP to google.com or the connection from the your computer to the Router/ISP.

Just let it run in the background and if there is connection error, it will be recorded.

It has been an issue on isps end, it’s fixed now. I have 100% packet loss when i try to ping my local gateway even when my internet is fine though.

Yes, a static IP assignment will bypass all DHCP configuration, including the assignments for routing and dns servers, so you must also manually configure those. Perhaps that is why you were seeing packet loss with a static IP assignment.

i did configure all of those when i tired manual configuration, i can’t ping my local gateway even now when my internet is fine though

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.