Looking for utility to display fan speed (like HWInfo64) and control it

Hey, looking for something like HWInfo64 for Manjaro. I run Windows 10 only for gaming but the main problem I got with Manjaro is the fan speed (looks like). On Windows my PC is silient before I start to play, on Manjaro it is not so I try to figure out but sensors over terminal just show me CPU :confused: Thx

You can try hardinfo GUI from the repos.

1 Like

Hi @MB7,

What I can think of quickly is lm_sensors, available from the repositories AFAIK.

Hope this helps.

Here’s a few:

1 Like

@codesardine hardinfo is something like Aida64, maybe even better and for free but not fan speed and temps like HWInfo64.

@Mirdarthos I run sudo sensors-detect and than I try lm_sensors (its installed) but “no command found”

maycne.sonahoz nothing helps, over Google I already search but only threads from 2015/2017, nothing with real time monitoring like HWInfo :frowning:

Welcome to Linux scripting:

$ watch -p -n 1 -d sensors

The command you’re looking for is sensors. There are also GUI applications and applets that use lm_sensors as back-end.

1 Like

That’s common in laptops where the BIOS does not reveal such info (fan info in your case) and it manages everything itself (controling the fans), you haven’t told us about your system, is it a desktop or a laptop?


Thank you @maycne.sonahoz. You beat me to it.

I didn’t know that myself, I just know lm_sensors is the right package. Personally, I use KDE widgets. My reason being that I’ve got enough resources and it looks better than good.

@leledumbo that good but it’s still nothing comapre to hwinfo64 :frowning:

I find Netdata, install it but I can not start it…

Maybe after reboot.

@MB7, you could consider to use fancontrol:


@Wollie I try this last time and after I run systemctl status fancontrol.service it shows 0 RPM which is wrong and after reboot I get this. Thats why I never try it again.

ERROR: Root device mounted successfully, but /sbin/init does not exist. Bailing out, you are on your own now. Good luck.

Sh: can’t access tty: job control turned off

[rootfs /]# _

full fledged application needs full fledged scripting solution as well if you want a fair fight :wink:
sensors doesn’t track anything else but thermal properties. The rest must be obtained from different utilities.

@leledumbo anyway thanks but thats sad :frowning:

It lives as a service and has a web UI, have you read the holy arch wiki entry?
As it runs for me. Still not a fair fight for hwinfo64, but in other way around. This tool is overkill.

Netdata does look nice indeed. But I’m pretty sure it does rely on the sensors data - like all the other linux utilities out there. So if you can’t get sensors working, I’m afraid you are out of luck.
You didn’t told us which DE you are on. For gnome I believe there is a sensors package and for KDE there is ksysguard. Personally I use the latter, which looks like this:

If you want to control fanspeed, you need to setup fancontrol (which is a PITA). But I believe there are also GUI for it. You can find all about it on the arch wiki.

@famo this fancontrol tool broke my PC :smiley:
It’s the only missing tools (Netlimiter and HWinfo64) but it looks like it is a real PITA and not working for the most (or maybe noob unfriendly) :frowning_face:
I use KDE btw