Long boot time on Manjaro

I have a problem with long boot time. It lasts 1 min. 30 sec or more. Can someone help me with this? Thanks.

systemd-analyze output:

Bootup is not yet finished (org.freedesktop.systemd1.Manager.FinishTimestampMonotonic=0).
Please try again later.
Hint: Use 'systemctl list-jobs' to see active jobs

systemd-analyze blame output:

21.458s plymouth-quit-wait.service
 1.318s systemd-random-seed.service
 1.236s vmware-networks.service
  518ms snapd.service
  419ms systemd-journal-flush.service
  365ms dev-nvme0n1p2.device
  222ms apparmor.service
  150ms cups.service
  146ms user@1000.service
  138ms ldconfig.service
  132ms polkit.service
   98ms systemd-modules-load.service
   93ms avahi-daemon.service
   89ms NetworkManager.service
   81ms systemd-sysusers.service
   79ms udisks2.service
   78ms systemd-logind.service
   70ms systemd-rfkill.service
   66ms lvm2-monitor.service
   64ms boot-efi.mount
   60ms ModemManager.service
   48ms systemd-udev-trigger.service
   47ms upower.service

systemd-analyze critical-chain output:

graphical.target @22.471s
└─multi-user.target @22.471s
  └─plymouth-quit-wait.service @1.012s +21.458s
    └─systemd-user-sessions.service @1.006s +3ms
      └─nss-user-lookup.target @1.734s

systemctl list-jobs output:

JOB UNIT                                                                        TYPE  STATE  
51  mnt-5aea3c0c\x2d5ee1\x2d4f57\x2d8b3f\x2d5c817574344f.mount                  start waiting
47  mnt-eaa0326f\x2d291a\x2d412d\x2d86aa\x2d25faded3b30c.mount                  start waiting
52  dev-disk-by\x2duuid-5aea3c0c\x2d5ee1\x2d4f57\x2d8b3f\x2d5c817574344f.device start running
48  dev-disk-by\x2duuid-eaa0326f\x2d291a\x2d412d\x2d86aa\x2d25faded3b30c.device start running

Well that seems to be taking forever and is not standard to a manjaro install…

It would appear that plymouth-quit-wait.service is the culprit. I would suggest… :arrow_down:

sudo systemctl disable --now plymouth-quit-wait.service

I know that is not happens only on Manjaro.

Thanks. I used this command, but after reboot nothing changed.

Then… uninstall Plymouth, maybe? :arrow_down:

sudo pacman -R plymouth