Logitech wireless mouse getting disabled on battery with tlp, powertop, laptop mode tools

I recently switched to manjaro from elementary on my amd ryzen 5 laptop. Installed tlp with tlpui, powertop, laptop-mode-tools.

Added my usb device to blacklist under usb auto suspend, still on battery, Logitech b160 wireless mouse stops working till I restart.

Getting like 1hr 30 mins max on battery. Windows gives 2 hr 30 mins.

Have tried disabling usb auto suspend altogether, changed conf file to 0, but still same result. Any suggestions? Removing them completely resolves the issue though.

Edit:added some more details.

TLP and LMT running together will cause a conflict of interest, just pick one and disable or remove the other. PowerTOP is still OK but its settings don’t survive across suspend-resume cycle. Lastly, use schedutil CPU governor, not powersave, not performance.

Hi THanks for the reply, I’m not trying to use both at the same time, i tried installing one after the other, but on battery mouse stops working on both tlp and lmt. same happens when powertop autotune is used.

OK, let’s try one by one. Starting from the easiest: powertop.

First things first, disconnect your laptop from power outlet, let it run on battery and then:

# powertop --calibrate

don’t touch anything during the process, let the screen goes black, wifi turned off and such. It’s probing your hardware. Once done:

# powertop --auto-tune

followed by:

# powertop

it may take a while to load, press Tab key until the Tunable tab, find the Logitech unifiying receiver (I believe your B170 uses this, can’t find B160 on the net I assume it’s a typo) then if it’s Good, press enter to make it Bad.

Let’s see how it goes.

OK, ran powertop calibrate,

Let it run for an hour after it completed on battery, then tried auto-tune, immediately mouse stopped working,

Went into powertop and changed the unifying receiver to Bad, (its b170 not 160 sorry about that), mouse wasn’t working, turned off mouse, unplugged receiver and re-plugged still wasn’t working,

Had to restart the system. Mouse started working but powertop settings had reverted.

Guess forget powertop then, either your USB port or the receiver doesn’t like power saving at all.

Let’s try TLP with TLP UI. Make sure TLP service is not running with:

# systemctl disable --now tlp

With your receiver unplugged, execute this:

$ lsusb > /tmp/before.txt

plug the receiver in, then:

$ lsusb > /tmp/after.txt
$ diff --suppress-common-lines /tmp/before.txt /tmp/after.txt | grep '^>' | awk '{print $7}'

take note on the <vendor id>:<product id> value. Now open TLP UI and go here:

Press that Edit button, find the previously emitted value and press its button down, press OK.

Enable and start the service:

# systemctl enable --now tlp

Let’s see how it goes this time.

Followed your steps, within seconds of enabling tlp mouse stops working.

Tried adding the LInux foundation usb root hub to the deny list as well, still the same.

To add, I had this exact same issue with elementary os as well.

Any solution for this, will power-daemon work well, i have used power-daemon without mouse freezing. Or should i just change the wireless mouse? if so which brand/model works without this issues?

Try this:

Disable runtime power management for AHCI devices:



No necro-bumping, please.