Logitech wireless keyboard does not work on some ARM64 Manjaro 21.07 distros

Now that the rolling setup does work, sort of, the KDE and Gnome distros do not like my Logitech wireless keyboard. The Logitech mouse does work and I can click through the setup to the user page. I can click into the various blocks but just can not type anything. A conventional USB keyboard and mouse does work OK.
The XFCE 21.07 distro seems to work OK. I was able to complete the XFCE setup, reboot and log in. Typing in LibreOffice and Firefox also worked.
I can write the KDE 20.12 file to an SD card, setup, log in, update and the wireless keyboard works.

What device are you installing the images on?

I’ve got Logitech keyboard and a Raspberry Pi.

Pi4 8 gig

One known issue is if you are using a 3.0 usb ssd drive it cause interference to wireless devices. You have to put some distance between the drive and the pi4 board. Another issue is interference from some monitors.

Not using any USB3 drives. Image flashed to Micro SD card.
I did set up the 21.07 Gnome with a conventional keyboard and mouse. Shut down, inserted the Logitech dongle, powered up the Pi-4 and was able to log in with the wireless keyboard and mouse. When the Gnome desktop loaded the mouse was able to start apps, LibreOffice and Firefox were tested, but the keyboard could not enter text into the apps. Seems as if there is an hardware conflict or an API missing in the desktop.

I have the same issue with Logitech MX Keys. I was able to complete the installation using another Microsoft Wireless keyboard. Once the system is installed my Logitech keyboard works normally.

This issue applies to version 20.07. In previous versions I was able to run and complete the install without issues with my Logitech Keyboard (20.06/20.04).

I tried one more time with the Mate Raspberry install. Success! Keyboard and mouse as well as everything else now works as it should work on my Pi 4 8 GB. Am very pleased with this distro and seem to use the Pi for more general browsing and etc.

1 Like

If you enable the on-screen keyboard in accessibility the Logitech keys work, However, if you turn it back off they stop working

My Logitech keyboard also fails to work in 21.10 Gnome distro during Install to Disk. I tried using Bluetooth keyboard to bypass this issue and have been able to complete the set up process successfully but upon reboot, I can’t log in because password authentication failures with multiple carefully typed password attempts. Anyone has any success using wired keyboard or other workaround?

unplug plug? sometime it works for me, do you have solaar-git package ?

During Gnome installation to disk process on the RPI4, The Logitech USB K350 keyboard has been working perfectly until the add user/password screen at which point, it stops working, accepting no input no matter what I type. If quitting the process, then the keyboard works again at the desktop. This problem is software repeatable and I have not plugged/unplugged the USB

is it possible to skip passwd login then go back after keyboard is set (for graphic environment)?