Login screen not working after update reboot


Yesterdat I’ve upgraded Manjaro and turned off the laptop. Today when I boot it up, the login screen is not working and displaying an error message:

"The current theme cannot be loaded due to the errors below, please select another theme.

file:///usr/share/sddm/themes/breath/Main.qml:26:1: plugin cannot be loaded for module “org.kde.plasma.core”: Cannot load library /usr/lib/qt/qml/org/kde/plasma/core/libcorebindingsplugin.so: (liblist-2.0.so.3: no s’ha pogut obrir el fitxer d’objecte compartit: El fitcer o directoi no existeix)"

Attached an image of the error. I have encrypted the boot partition and autologon enabled.

Can you help me, please?

there is no image…
enter into tty in the stuck screen: ctrl+alt+f2 or f1-f6 keys, enter your username/password, and rerun update again:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

if no errors and you are up to date, reinstall liblist:
sudo pacman -S libplist
if no errors, reboot:
systemctl reboot

I’ve run into this same problem. I had to drop to shell and then run:
sudo pacman -S libusbmuxd
This shows the conflict with libusbmuxd-git and asks to uninstall. After that, I ran:
sudo pacman -S libplist
It also conflicts with its -git counterpart which I uninstalled and was the able to reboot to the desktop.

When I again run:
sudo pacman -Syyu
it attempts to update libimobiledevice
which then re-installs the -git packages re-breaking the system. For now, I’m just avoiding updating.

I am having the same issue as OP. Can’t seem to find a solution. I have run the recommended cmd’s but no luck.
When I run sudo pacman -S libplist I get libplist and libplist-git are in conflict.

If you follow the commands in my post in that order, it should work for you. It will ask if you want to replace the conflicting package. Just say yes and proceed. Repeat for the next package. Should work.

@MaddestMax I tried that and it did not work for me. I will try it again to make sure I did not miss something?

post the output of the commands

I will post output today when I get back to the machine in question.


libplist and libplist-git are in conflict. Remove libplist-git? [y/N]

I restored the machine with time shift. If I install the current testing updates it breaks it again.

That doesn’t make much sense because libimobiledevice is in Manjaro repos and in no way it can depend on AUR packages. But I believe you and something is trying to pull packages from AUR. Can you disable AUR in pamac and try to update again?

So, yes. You remove both -git packages and replace them.

:thinking: I didn’t catch that, but you’re right. It’s really strange. I ended up messing with it a bit more that day, and it “fixed itself”. I think the 3rd time I ran through the whole process, when I ran update it just didn’t pick up anything. I figure there was an order error somehow and it sorted itself out. Maybe magic. :magic_wand::smirk:

post output from:
pacman -Qm
you may have more packages installed from aur that are also in official repos…

Here is the output of pacman -Qm

bluebubbles-desktop-app 1.0.3-1
google-chrome 113.0.5672.63-1
ifuse-git 2:1.1.4.r5.g814a0e3-1
libimobiledevice-git 1:1.3.0.r174.g9a5e78f-1
libimobiledevice-glue-git r37.6fcb879-1
libplist-git 1:2.2.0.r123.g4c8844d-1
mailspring 1.10.8-1
python2 2.7.18-8
systemd-fsck-silent 239-1
teamviewer 15.41.7-1
ttf-ms-fonts 2.0-12
ultravnc-viewer 1.3.2-1

so uninstall the AUR ones:

sudo pacman -Rdd ifuse-git libimobiledevice-git libimobiledevice-glue-git libplist-git

install them from official repos:

sudo pacman -S ifuse libimobiledevice libplist

rerun update:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

if no errors, reboot


Finally I can fix it:

First I’ve searched all the gitpackages installed and replaced it with the official packages:

pacman -Qs git

sudo pacman -S kcoreaddons kdbusaddons kwindowsystem kcodecs kconfig kirigami2 kquickimageeditor knotifications ki18n kauth kconfigwidgets kcrash kfilemetadata kglobalaccel kjobwidgets kpackage kservice kwallet purpose syndication kcompletion kdeclarative kded kiconthemes kio knewstuff ktextwidgets kxmlgui signon-kwallet-extension kaccounts-integration kbookmarks kcmutils knotifyconfig

1 Like

You’re a life saver! Couldn´t see the login screen anymore after booting, after the update last week. Replaced qt-descriptive-git with qt-descriptive, and voila!

Got it! Thanks that did the trick.