Login screen freezes after entering password

I have used windows for my entire life, so pardon me if I don’t give enough information or ask something that should be a common sense for a Linux user. I have used Ubuntu for just one month and that’s all the experience I have with Linux

I have i3(3.3GHz), Nvidia GeForce 510, 4GB ram and HDD… I am on dual boot with windows 10(which is working fine) and manjaro linux xfce. The login screen freezes after entering my password and it doesn’t take any input at all… I have tried unplugging and plugging in PC and sometimes it works but mostly it doesn’t… I am able to open CLI before entering my password but as soon as I enter the password, screen freezes again… I have tried to reinstall manjaro but no luck… I have searched online and in forums, other people have the same issue but can’t get a clear solution or maybe I am too noob to understand… Can anyone please help me with this… Thank you in advance…

This is my inxi output:

  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64
  root=UUID=0ae4cef4-730a-44dc-bfd5-2bbfd3001538 rw quiet apparmor=1
  security=apparmor resume=UUID=4344f7c7-06fa-4e70-b3f5-745463055c56
  Console: tty 4 DM: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: LENOVO product: Lenovo H420 v: Lenovo serial: <filter>
  Mobo: LENOVO model: N/A serial: <filter> BIOS: LENOVO v: DPKT23A
  date: 01/13/2012
  Message: No system battery data found. Is one present?
  RAM: total: 3.82 GiB used: 478.4 MiB (12.2%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: Dual Core model: Intel Core i3-2120 bits: 64 type: MT MCP
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F
  cache: L2: 3 MiB bogomips: 26350
  Speed: 1662 MHz min/max: 1600/3300 MHz Core speeds (MHz): 1: 1662 2: 1596
  3: 1596 4: 1606
  Flags: acpi aperfmperf apic arat arch_perfmon avx bts clflush cmov
  constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept est
  flexpriority flush_l1d fpu fxsr ht ibpb ibrs lahf_lm lm mca mce md_clear mmx
  monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs
  pge pln pni popcnt pse pse36 pti pts rdtscp rep_good sep ssbd sse sse2
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_deadline_timer
  vme vmx vnmi vpid xsave xsaveopt xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GF119 [GeForce 510] vendor: Micro-Star MSI driver: nvidia
  v: 390.144 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1042
  class-ID: 0300
  Display: server: X.org 1.20.13 driver: loaded: nvidia tty: 128x48
  Message: Advanced graphics data unavailable in console. Try -G --display
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
  vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  chip-ID: 8086:1c20 class-ID: 0403
  Device-2: NVIDIA GF119 HDMI Audio vendor: Micro-Star MSI
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0e08
  class-ID: 0403
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.38 running: no
  Device-1: Intel 82579V Gigabit Network vendor: Lenovo driver: e1000e
  v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1503 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce
  v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8176 class-ID: 0280
  IF: wlp3s0 state: down mac: <filter>
  IF-ID-1: enp0s29u1u2 state: unknown speed: -1 duplex: half mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: vivo I2011 type: USB driver: rndis_host v: kernel bus-ID: 2-1.2:6
  chip-ID: 2d95:600a class-ID: 0a00 serial: <filter>
  Report: This feature requires one of these tools: hciconfig/bt-adapter
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 465.76 GiB used: 13.01 GiB (2.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD5000AAKX-083CA1
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
  type: HDD rpm: 7200 serial: <filter> rev: 1H19 scheme: MBR
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVD-RAM GH70N rev: NYA2
  dev-links: cdrom
  Features: speed: 40 multisession: yes audio: yes dvd: yes
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 81.25 GiB size: 79.42 GiB (97.75%) used: 13.01 GiB (16.4%)
  fs: ext4 dev: /dev/sda7 maj-min: 8:7 label: N/A
  uuid: 0ae4cef4-730a-44dc-bfd5-2bbfd3001538
  ID-2: /boot/efi raw-size: 800 MiB size: 798.4 MiB (99.80%)
  used: 4 KiB (0.0%) fs: vfat dev: /dev/sda5 maj-min: 8:5 label: NO_LABEL
  uuid: 4E87-7DBF
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 15.62 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/sda6 maj-min: 8:6 label: N/A
  uuid: 4344f7c7-06fa-4e70-b3f5-745463055c56
  ID-1: /dev/sda1 maj-min: 8:1 size: 50 MiB fs: ntfs label: System Reserved
  uuid: F8CC4F76CC4F2E66
  ID-2: /dev/sda2 maj-min: 8:2 size: 97.61 GiB fs: ntfs label: N/A
  uuid: 78A25798A2575A28
  ID-3: /dev/sda3 maj-min: 8:3 size: 270.45 GiB fs: ntfs label: N/A
  uuid: C00A4FA10A4F9378
  ID-4: /dev/sda4 maj-min: 8:4 size: 1 KiB fs: <superuser required> label: N/A
  uuid: N/A
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 1-1.2:3 info: Lenovo Black Silk Keyboard type: Keyboard,HID
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 1.5 Mb/s
  power: 100mA chip-ID: 17ef:602d class-ID: 0300
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
  speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 2-1.1:3
  info: SHARKOON 2.4GHz Wireless rechargeable vertical mouse [More&Better]
  type: Mouse driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s
  power: 100mA chip-ID: 1ea7:0064 class-ID: 0301
  Device-2: 2-1.2:6 info: vivo I2011 type: Bluetooth,CDC-Data
  driver: rndis_host interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
  chip-ID: 2d95:600a class-ID: 0a00 serial: <filter>
  Device-3: 2-1.4:4 info: Genesys Logic SD/MMC card reader type: Mass Storage
  driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA
  chip-ID: 05e3:0722 class-ID: 0806 serial: <filter>
  System Temperatures: cpu: 39.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 151 Uptime: 19m wakeups: 0 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: N/A Packages: 1095 pacman: 1087 lib: 332 flatpak: 0 snap: 8
  Shell: Bash (login) v: 5.1.8 running-in: tty 4 inxi: 3.3.08

can you switch to TTY before the FREEZE and login there ? (Alt-Ctrl-F1)

1 Like

Yes I can login there but I don’t know other commands or what to do there… Someone said ut must be nvidia proprietary driver issue and I should switch to open source one but I have no idea how to do that

Hi from telegram :wink:

Please start here (and provide an inxi output):

1 Like

Oh … you may have trouble doing that without the following two guides:

[HowTo] Resolve an unbootable Manjaro (black screen, login failed, cant boot, etc)

[HowTo] use public command-line pastebin services without installing anything!

1 Like