Login loop on x11 and wayland, TTY broken also


As said in the title my system seems completely broken.
I tried wayland a few days/weeks ago, not fully stable, At the same time i tried kwinft also but it completely broke the wayland session (login to black screen if i remember well) so i got back on X11 and reinstalled kwin ( all through the GUI tool)
X11 seemed to worked fine, wayland was still broken with a login loop though.

Along these few days i noticed a few times that the system doesn’t shutdown properly, just staying on with a black screen indefinitely. I had to shutdown with the reset button. Beside that it was fine.

Yesterday I executed these two commands :

cd $HOME ; wget https://raw.githubusercontent.com/gabomdq/SDL_GameControllerDB/master/gamecontrollerdb.txt ; grep Linux gamecontrollerdb.txt | grep -v '# Linux' > .controller_config ; sed -i '1s/^/export SDL_GAMECONTROLLERCONFIG="/' .controller_config ; sed -i '$s/$/&"/' .controller_config
grep -q controller_config .bashrc || echo '. "$HOME/.controller_config"' >> .bashrc ; grep -q controller_config .bash_profile || echo '. "$HOME/.controller_config"' >> .bash_profile ; grep -q controller_config .profile || echo '. "$HOME/.controller_config"' >> .profile

I closed up my session and rebooted and now i’m stuck in a login loop with both x11 and wayland, i tried to do something with the TTY but it seems broken also. I can login with it, but i can’t execute any command.

I always get “-bash: /usr/bin/ls: Liste d’arguments trop longue”, “Too many arguments” in English i guess.

It’s the same with other command: /usr/lib/pk-command not found, usr/bin/sudo, and so on. The only things that worked was “cd --help” printed the help, echo “something” printed something, but all the commands i tried were broken.

I don’t think it has anything to do with the controller variable, I don’t see how this could break my system.

Also i tried to boot with a timeshift, to get back 3days before but it didn’t change anything, i don’t know what files are changed, but apparently not the ones that causes my troubles.

I will probably reinstall anyway at this point, but i’m curious about what happened to break my system so deeply.

I searched on the web but I didn’t found anything similar. I don’t know where to start.

If someone has any leads about what i should look into, I’m not an advanced user, but I’d like to improve my knowledge :sweat_smile:

my assessment:
your second command probably messed up your ~/.bashrc and ~/.bash_profile

it wrote some stuff to it - appended it to what was there already

restore it to original - in /etc/skel is the original

None of what you did destroyed your system - just your shell startup file(s) are … messed up

You can access your installation from a live medium - and repair it that way
take care of proper permissions if and when you replace ~/.bashrc

But perhaps you did something else as well but don’t remember …