Login keyring not accessible with gnome-keyring 42 on xfce with x2go

I am on a fresh Manjaro, and did the additional testing in virtualbox with the same result.
I use xfce under x2go. Until gnome-keyring 40 everything was working. Login keyring listed in seahorse, I was able to unlock, and all the automatic login actions worked.

After the upgrade to 42, seahorse not listing the login keyring, and I am unable to unlock it.

If I upgrade the system excluding gnome-keyring, sticking with version 40, it is working.

I use the following command to start the xfce session:

dbus-launch /usr/local/bin/xfce4-session-x2go.sh

/usr/bin/xfce4-session > /dev/null’

  • no modificatons in /etc/pam.d/login
  • in xfce settings, the ‘Start GNOME serivces on startup’ is active
  • in xfce settings, the following startup applications are turned on:
    • gnome-keyring-pkcs11
    • gnome-keyring-secrets
    • gnome-keyring-ssh

Interestingly when I downgrade gnome-keyring to 40, the problem remains.

More interestingly, with the mate desktop, everything is working from x2go, with both versions.

Logging into the system normally (not x2go), everything is working fine, even after the upgrade.

The only difference I see is that the version gnome-keyring:42 packaging uses systemd to start gnome-keyring.