Login Failed on Manjaro linux session

So I’ve been using my computer all morning, I left it for lunch and when I came back it was in the login screen. As always I put the password and suddenly it says login failed, Of course maybe I put it wrong or something. I tried like 10 times and I know that that is the correct password, but for some reason I can’t nor login normally or by the tty2 command line. It tells me the same, login incorrect, but I know that that is the correct password. This is the first time I get this problem, I don’t want to

Does anyone know what can I do to enter my session? I writing this from my dual boot windows where I can login as usual.

I haven’t done much this morning, at that moment I was installing zsh for my terminal and just updated some minor packages.

Hi @eneko98, and welcome!

After having experienced that exact same thing, I have to ask, did you try again after a reboot? If not, do so.

I still don’t know why this happened or how to fix it. The way I ‘fixed’ it was by losing my temper, running out of patience and doing a reinstallation.

Yep I tried rebooting but nothing for now, I hope I don’t have to do a reinstallation cause I have many files in my Manjaro boot…

For your part, I also hope you don’t have to.

Let this be a lesson to you, and everybody else that reads this why backups is a very good and important thing to have available.

Maybe you could reset the password via a chroot session?

Alright I’ll try that, can you tell me how to reset the password? I assume you need to use a live USB and use a terminal in there.

Yes, I didn’t think of this when I had the problem. And anyway, I was not yet comfortable using a chroot environment. To do this:

  1. Boor from a Live ISO and copy/write/whateveryouwannacall t to some media so that you have a live environment ISO.
  2. Once the Live environment has finished booting, open a terminal.
  3. In thee Live ISO environment, in the terminal, tun:
manjaro-chroot -a
  1. Select your Manjaro installation to enter the chroot environment.

Be careful from here on, because y6ou are now root on your actual installation.

  1. Run:
passwd <username>

Where <username> is the username of your system.

  1. Follow the prompts. When done and wishing to exit the chroot environment, enter

and close the terminal:

  1. Hold your breath, your thumbs, say a little prayer, and reboot.

In all theory, it should work now. If it does, feel free to heap thee praise on. If not, well, then it wasn’t me and I’m totally innocent.

Really hope this helps!

What should I do now? Just go with my username and passwdpasswd?

From here on further, AFAIK.

Yep, I tried it. i got into the chroot, changed the password successfully but when I got into my session nothing changed, it still says login failed. Seems like I’ll have to install manjaro again, I saw that I can take my files from the live USB back so I’ll install it again… Thank you for your help!

Sorry then, and you’re welcome!

Wish I knew what causes this…

I am no expert in chroot, but maybe you could create a new user from within chroot and then try logging in there. If it works, it might be better than doing a reinstall :sweat_smile:.

This might work, although I haven’t tested it.

If it’s a system-wide thing, there exists the chance that it won’t. But, as I said, I haven’t done it, so wouldn’t know.

See here for more about creating a user from CLI (which would be necessary to create it from a chroot environment.): https://linuxize.com/post/how-to-create-users-in-linux-using-the-useradd-command/

1 Like

I’m not sure if I understand rigth, but it seems to me that you made some kind of partial update, that can leed to this.

You should manjaro-chroot again and search for clues in the system log with:

journalctl -b -1

Also you can do a full update of your system, just in case, with:

pamac update

This might explain it. I didn’t think about this then, and I didn’t think about it now.

Boot into a live ISO environment, enter a chroot environment, as before, and complete the update by running:

pamac upgrade

When you’re done, merge any .pacnew files:

sudo DIFFPROG=meld pacdiff

If meld isn’t installed, install it first:

pamac install meld