Keyboard does not work on login

My keyboard has stopped working on the login screen after a restart. Now, when the lightdm login screen shows up, when I press any key on the keyboard, the keyboard turns off its backlight and does not respond in any way. It works on grub and bios. My mouse works in all cases. Some hardware details:

  • Desktop PC
  • External wired USB keyboard. I have tried two keyboards and the exact same behavior
  • Wireless logitech mouse
  • No GPU, only integrated
  • CPU: Ryzen 3600G
  • 512gb Samsung NVMe storage
  • 32 Gb of ram


  • Installed kernel: 5.12 but I have tried 5.10 and 5.9 from grub, same results.
  • i3wm (community build)
  • No double boot etc.
  • I had already restarted after a kernel update

Observed Behaviour:
I had installed some games over steam and went doing some chores. I came back, logged in (keyboard worked) then when I was watching some videos, only the background music would play. I have restarted pulseaudio, same behavior. Unplugged and replugged headset (I use a USB DAC), same behavior. I didn’t have many things running on my computer so I have decided to restart and I ended up in my current situation.
Only thing I can think of is that I have downloaded too much content, occupied too much storage and something went off. I should have still 60GB storage left though.

If I cannot find a solution, I’ll go to work tomorrow, bring my work computer, check stuff with a linux downloaded usb stick

Note: I am writing this from my phone with no other computer available at home other than a Raspberry Pi.

Regarding downloading from Steam or similar platforms, can it download 10gb, extract it and overwrite some stuff?

Hi, eko1!

I have only

check for space

May be it not the case to think only. It’s time to sync with reality: to be sure that it is not a free space problem.


to update

Installed kernel: 5.12 but I have tried 5.10 and 5.9 from grub, same results.

Why only that selection? 5.9 and 5.12 are End-of-life. current 5.10 has bugfix number not less than 70 in the stable updates branch.
Did you know that already was 5.13 and now it is EoL but for a couple of weeks will be still available in Manjaro? Also 5.14 is current, 5.15 is available, but for now it is currently in beta.
May be using other kernel versions could fix that keyboard behavior.

But first, may to find a fresh server to get updates from and to update all the packages you have?

If to update, consider to do this:

sudo pacman-mirrors -B unstable -a -c Sweden -P https  

(or any your country)
and than

sudo pacman -Syyu

to reboot and than to pdate AUR packages (if you have them)

pamac update -a --force-refresh

May be to use other keyboard meantime of you have it?
Or to do all via GUI: may be login screen have a virtual (on-screen) keyboard.
Or to try to load Live USB (may be the same keyboard will work) and “chroot” and to check out journalctl logs, to update the installed system from within Live USB session.

“chroot” - I mean “manjaro-chroot”: Login Failed on Manjaro linux session - #7 by Mirdarthos
the same instruction, but change password stuff to OS update stuff suggested in this my post.


Thank you @alven ! I have tried your suggested fixes by going through chroot from a Live USB setup. However, they did not work at all. Then I went through the journalctl logs and saw something like not enough power to the USB and some errors about the mouse. Then I have unplugged all USB devices except my keyboard and I managed to login! My guess is that everything is initialized before the keyboard and pressing one key draws the last bit of power and it shuts down. I have quite a bit of USB powered devices and my latest USB-DAC (a Dragonfly black) is the main culprit. I will do some tests and let people know. Still a very weird behavior.

1 Like

Max USB 2.0 ports electrical current is 0.5A.
Weakest USB 3.x ports max electrical current is 0.9A.
Try to switch some devices: low power into USB 2.0, the keyboard to USB 3.x.

It should be not a PSU issue: probably with USB devices a desktop PowSupUnit can’t be overloaded (or may be it is so old? but I estimate the probability of that is close 0%)