Lock screen isn't working correctly

I’ve found two issues:

  1. Last night, I put my pc into sleep mode. But when I opened it again, it didn’t ask for the password.
  2. The network applet in the system tray locks everything until it get connected to Wi-Fi, even the lock screen. The desktop is visible with all the windows opened. Only when it gets connected to the internet, the log-in screen appears.
  Host: sz97-x555lf Kernel: 5.15.81-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.26.4 Distro: Manjaro Linux
  Type: Laptop System: ASUSTeK product: X555LF v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X555LF v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: X555LF.603 date: 04/16/2019
  ID-1: BAT0 charge: 21.2 Wh (87.6%) condition: 24.2/37.3 Wh (64.9%)
    volts: 7.5 min: 7.5
  Info: dual core model: Intel Core i3-5010U bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 1979 min/max: 500/2000 cores: 1: 1925 2: 1997 3: 1997
    4: 1997
  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel
  Device-2: NVIDIA GM108M [GeForce 930M] driver: N/A
  Device-3: Chicony USB2.0 VGA UVC WebCam type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5 driver: X:
    loaded: modesetting dri: iris gpu: i915 resolution: 1366x768~60Hz
  API: OpenGL v: 4.6 Mesa 22.2.4 renderer: Mesa Intel HD Graphics 5500 (BDW
  Device-1: Intel Broadwell-U Audio driver: snd_hda_intel
  Device-2: Intel Wildcat Point-LP High Definition Audio
    driver: snd_hda_intel
  Sound API: ALSA v: k5.15.81-1-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.61 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp2s0 state: down mac: 2c:56:dc:18:ee:63
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    driver: ath9k
  IF: wlp3s0 state: up mac: 80:a5:89:56:d5:89
  Device-1: IMC Networks type: USB driver: btusb
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 465.76 GiB used: 110.14 GiB (23.6%)
  ID-1: /dev/sda vendor: Western Digital model: WD5000LPVT-08G33T1
    size: 465.76 GiB
  ID-1: / size: 39.07 GiB used: 18.79 GiB (48.1%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 391.2 MiB used: 13.3 MiB (3.4%) fs: vfat
    dev: /dev/sda4
  ID-3: /home size: 132.81 GiB used: 91.34 GiB (68.8%) fs: ext4
    dev: /dev/sda3
  ID-1: swap-1 type: partition size: 7.71 GiB used: 0 KiB (0.0%)
    dev: /dev/sda1
  System Temperatures: cpu: 36.0 C pch: 33.5 C mobo: N/A
  Fan Speeds (RPM): cpu: 2300
  Processes: 208 Uptime: 11h 10m Memory: 11.59 GiB used: 2.74 GiB (23.7%)
  Shell: Zsh inxi: 3.3.24

No, it works correctly, but the bottleneck is rather your HDD:

Note that the “lock screen” is an additional program. So on kde it is sddm.

If you lock the screen and then suspend, then it should work as intended.

If you look at:

systemctl list-dependencies graphical.target 

Each Services on a target run in parallel, but targets run in steps.

You see that NetworkManager.service is part of multi-user.target.

Now I guess the services NetworkManager-wait-online.service is the stopper,

systemctl list-dependencies NetworkManager-wait-online.service   

which depends on NetworkManager.

So at the end: It will not start the “lock screen” until it has a internet connection on wakeup. The “screen lock” have to be started and then suspend. On wake up the screen lock appears normally then.

On fast SSDs you will not experience that issue, but on slow HDDs.

Then please change the suspend button behaviour of the application launcher.

You ask me, who is not a dev of kde and not part of ManjaroTeam and even don’t use KDE Plasma at all, to change it? Hmhm :thinking: I am the wrong person.

Report it upstream to the kde devs. That would be a better advice, since Manjaro doesn’t develop KDE, or change it yourself.

However… just think that a lock screen on Xorg is a hacky thing. Wayland seems not to have this problem. Maybe try that, but on the other side wayland is still in progress of development, so expect not a 100% bug-free environment.

EDIT: On I3 with a slow laptop on a 5400RPM HDD I experience the same with blurlock, but it doesn’t happen with GDM and Gnome on the same machine (when I remember correctly). So might a specific plsama and sddm problem.