Lock screen is broken and HDMI/USB C external display non-functioning

Model: thinkpad L14 Gen 1

CPU/ graphics: AMD Ryzen 5 PRO 4650U with Radeon Graphics
RAM: 16 gb

$ qmake --version                                                                                                                0|1 ✘ 
QMake version 3.1
Using Qt version 5.15.4 in /usr/lib

Two in one because I believe they are related to one another in context of the graphics software.

So originally when I installed manjaro both of these problems did not exist. They creeped in as I added more packages.

The lock screen bug appears when i put my system into sleep then wake it up, I get a black screen with white text basically saying its broken and need to restart my computer.
I thought it was down to the QT versions as when I ran
journalctl --since today | grep “lock”

there was a version mismatch between QT versions in context of incompatibilities so I reinstalled the qt-base from the package manager GUI but still no luck.


The HDMI did work before with zero problems, USB C never worked actually although the dock did turn on and I could access my USB through it. I am really not sure how to solve that one.

When I have the HDMI plugged in and USB C …

$ xrandr --listproviders                                                                                                             ✔  
Providers: number : 1
Provider 0: id: 0x46 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 4 associated providers: 0 name:modesetti

Please help assist me in getting this system working to its full potential, thank you

provide info:
inxi -Fazy
mhwd-kernel -li && mhwd -l && mhwd -li
journalctl --boot=0 --priority=3 --no-pager

create a new user and test with it, if you have still the same issues

inxi -Fazy


  Kernel: 5.15.41-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=7ef16763-911c-4386-8131-2910e731fe78 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20U5S0NQ00 v: ThinkPad L14 Gen 1
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20U5S0NQ00 v: SDK0T76538 WIN
    serial: <superuser required> UEFI: LENOVO v: R19ET36W (1.20 )
    date: 07/12/2021
  ID-1: BAT0 charge: 37.9 Wh (82.0%) condition: 46.2/45.7 Wh (101.0%)
    volts: 11.9 min: 11.1 model: SMP LNV-5B10W13896 type: Li-poly
    serial: <filter> status: discharging cycles: 20
  Info: model: AMD Ryzen 5 PRO 4650U with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600106
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1395 high: 1397 min/max: 1400/2100 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1397 2: 1397
    3: 1392 4: 1386 5: 1395 6: 1394 7: 1397 8: 1397 9: 1397 10: 1397 11: 1396
    12: 1397 bogomips: 50323
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1
    bus-ID: 06:00.0 chip-ID: 1002:1636 class-ID: 0300
  Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 4-3:2
    chip-ID: 5986:212b class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: modesetting gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x08c7 built: 2019 res: 1920x1080
    hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.42 5.15.41-1-MANJARO)
    v: 4.6 Mesa 22.0.4 direct render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 06:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x pcie: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 06:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 06:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.41-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3400 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0f0 state: down mac: <filter>
  Device-2: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
    vendor: Lenovo driver: rtw89_8852ae v: N/A modules: rtw_8852ae pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8852
    class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 4-4:3 chip-ID: 0bda:4852 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 48.8 GiB (10.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFS512GDE9X081N
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 41720C20 temp: 40.9 C scheme: GPT
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%)
    used: 48.8 GiB (10.4%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 0
  Processes: 321 Uptime: 17m wakeups: 4 Memory: 15.06 GiB
  used: 4.05 GiB (26.9%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1328 lib: 343 flatpak: 0
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.16

mhwd-kernel -li && mhwd -l && mhwd -li

The following kernels are installed in your system:
   * linux515
> 0000:02:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:06:00.0 (0300:1002:1636) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

May 29 21:51:20 rey systemd-modules-load[309]: Failed to find module 'nvidia-uvm'
May 29 21:51:21 rey kernel: tpm tpm0: [Firmware Bug]: TPM interrupt not working, polling instead

Failed to find module 'nvidia-uvm’

Hmm ok so it’s looking for this package but can’t find it; not jumping ahead here but the nvidia package seems to be causing issues and seems relevant to this issue @brahma sorry for the late reply btw

its looking for a nvidia module, but since you dont have any nvidia hardware … did you had it one time? open the app/remove software app and search for nvidia, and click installed on the left side…
and also did you try with the new user?
post output from this:
find /etc/X11/ -name "*.conf"

I apologize for the long replies between your responses
the result of running the requested command is


the optimus manager is for switching hardware drivers… I am thinking that’s the issue

removed optimus and re-ran the command it only shows the first two now

@brahma I did not try with a new user yet

and why did you had optimus installed? did you have dual graphics at one time… and after you uninstalled optimus, did you rebooted and checked if you still have the issue?

I installed the wrong package and realised it was not what I wanted; it was shortly after that I got had those issues. I rebooted when I uninstalled and the issue with the HDMI port was resolved but my screen lock still is a problem I cannot make my computer sleep without rebooting it…


Lock screen broke due to a - Syu

HDMI broken from installing optimus